View Issue Details

IDProjectCategoryView StatusLast Update
0003010SymmetricDSImprovementpublic2017-03-14 08:09
ReporterchensonAssigned Tochenson 
PrioritynormalSeverityminorReproducibilityhave not tried
Status closedResolutionfixed 
Product Version3.8.18 
Target Version3.8.18Fixed in Version3.8.18 
Summary0003010: Batches get stranded in ready state in staging on a cluster because the ack that moves them to done occurs on a different server
DescriptionBatches get stranded in ready state in staging on a cluster because the ack that moves them to done occurs on a different server.

Getting rid of the READY state in favor of just CREATE and DONE. When a batch is finished extracting it will go to directly to DONE. This should be fine with the new staging purging strategy of waiting until the outgoing or incoming batch has been purged. If the old purging strategy in employed, then a batch will be purged after the ttl hits. This means that the ttl needs to be longer than the longest amount of time it takes to extract. This is ok because it is advanced behavior (you have to explicitly turn on the old purge strategy).
TagsNo tags attached.

Activities

There are no notes attached to this issue.

Related Changesets

SymmetricDS: 3.8 28dbfdc7

2017-03-10 15:25:03

chenson

Details Diff
0003010: Batches get stranded in ready state in staging on a cluster
because the ack that moves them to done occurs on a different server

0003010
mod - symmetric-core/src/main/java/org/jumpmind/symmetric/file/FileSyncZipDataWriter.java Diff File
mod - symmetric-core/src/main/java/org/jumpmind/symmetric/service/impl/AcknowledgeService.java Diff File
mod - symmetric-core/src/main/java/org/jumpmind/symmetric/service/impl/DataExtractorService.java Diff File
mod - symmetric-core/src/main/java/org/jumpmind/symmetric/service/impl/FileSyncService.java Diff File
mod - symmetric-io/src/main/java/org/jumpmind/symmetric/io/data/writer/SimpleStagingDataWriter.java Diff File
mod - symmetric-io/src/main/java/org/jumpmind/symmetric/io/data/writer/StagingDataWriter.java Diff File
mod - symmetric-io/src/main/java/org/jumpmind/symmetric/io/stage/IStagedResource.java Diff File
mod - symmetric-io/src/main/java/org/jumpmind/symmetric/io/stage/StagedResource.java Diff File
mod - symmetric-io/src/main/java/org/jumpmind/symmetric/io/stage/StagingManager.java Diff File

SymmetricDS: 3.8 643a0832

2017-03-12 10:51:32

chenson

Details Diff
0003010: Batches get stranded in ready state in staging on a cluster
because the ack that moves them to done occurs on a different server.
Can't delete memory batches on DONE now that READY is gone.

0003010
mod - symmetric-io/src/main/java/org/jumpmind/symmetric/io/stage/StagedResource.java Diff File

SymmetricDS: 3.8 4f1def02

2017-03-13 07:57:47

chenson

Details Diff
0003010: Batches get stranded in ready state in staging on a cluster
because the ack that moves them to done occurs on a different server.
Don't remove in memory resource from staging manager list of resources
when its status goes to DONE.

0003010
mod - symmetric-core/src/main/java/org/jumpmind/symmetric/model/OutgoingBatch.java Diff File
mod - symmetric-io/src/main/java/org/jumpmind/symmetric/io/stage/StagedResource.java Diff File

Issue History

Date Modified Username Field Change
2017-03-10 15:24 chenson New Issue
2017-03-10 15:24 chenson Status new => assigned
2017-03-10 15:24 chenson Assigned To => chenson
2017-03-10 15:24 chenson Description Updated View Revisions
2017-03-10 15:28 chenson Status assigned => resolved
2017-03-10 15:28 chenson Fixed in Version => 3.8.18
2017-03-10 15:28 chenson Resolution open => fixed
2017-03-10 16:00 chenson Changeset attached => SymmetricDS 3.8 28dbfdc7
2017-03-12 11:00 chenson Changeset attached => SymmetricDS 3.8 643a0832
2017-03-13 08:00 chenson Changeset attached => SymmetricDS 3.8 4f1def02
2017-03-14 08:09 chenson Status resolved => closed