View Issue Details

IDProjectCategoryView StatusLast Update
0003623SymmetricDSBugpublic2018-07-10 14:00
ReportermmichalekAssigned Tommichalek 
PrioritynormalSeverityminorReproducibilityhave not tried
Status resolvedResolutionfixed 
Product Version3.9.0 
Target Version3.9.10Fixed in Version3.9.10 
Summary0003623: Fix unintended side-effects involving push/pull node lists
DescriptionNodeService.findTargetNodesFor was returning a cached collection of nodes, which calling functions are able to mutate. This could lead to extra queries running during push, incorrect node lists on the pro console, and possibly other side effects.
TagsNo tags attached.

Activities

There are no notes attached to this issue.

Related Changesets

SymmetricDS: 3.9 48139ad3

2018-07-10 13:51:27

mmichalek

Details Diff
0003623: Fix unintended side-effects involving push/pull node lists
0003623
mod - symmetric-core/src/main/java/org/jumpmind/symmetric/service/impl/NodeService.java Diff File

Issue History

Date Modified Username Field Change
2018-07-10 13:51 mmichalek New Issue
2018-07-10 13:51 mmichalek Status new => assigned
2018-07-10 13:51 mmichalek Assigned To => mmichalek
2018-07-10 13:51 mmichalek Status assigned => resolved
2018-07-10 13:51 mmichalek Resolution open => fixed
2018-07-10 13:51 mmichalek Fixed in Version => 3.9.10
2018-07-10 14:00 mmichalek Changeset attached => SymmetricDS 3.9 48139ad3