View Issue Details

IDProjectCategoryView StatusLast Update
0004166SymmetricDSBugpublic2019-12-02 15:12
Reporterj.mackay@backinmotion.com.auAssigned Toelong 
Priorityhigh 
Status closedResolutionfixed 
Product Version3.11.0 
Target Version3.11.1Fixed in Version3.11.1 
Summary0004166: Purge not working when using prefix on sym tables.
DescriptionIt seems to be looking for table 'sym_data_event' when it should be looking for {sync.table.prefix}_data_event.
Additional Information2019-11-26 20:00:00,399 INFO [P047] [PurgeService] [P047-job-8] Failed to execute purge, but will try again, StackTraceKey.init [SqlException:4106366675]
org.jumpmind.db.sql.SqlException: Invalid object name 'sym_data_event'.
    at org.jumpmind.db.sql.AbstractSqlTemplate.translate(AbstractSqlTemplate.java:305)
    at org.jumpmind.db.sql.AbstractSqlTemplate.translate(AbstractSqlTemplate.java:294)
    at org.jumpmind.db.sql.JdbcSqlTemplate.execute(JdbcSqlTemplate.java:519)
    at org.jumpmind.db.sql.JdbcSqlTemplate.update(JdbcSqlTemplate.java:358)
    at org.jumpmind.symmetric.service.impl.PurgeService.purgeLingeringBatches(PurgeService.java:243)
    at org.jumpmind.symmetric.service.impl.PurgeService.purgeOutgoing(PurgeService.java:129)
    at org.jumpmind.symmetric.service.impl.PurgeService.purgeOutgoing(PurgeService.java:90)
    at org.jumpmind.symmetric.job.OutgoingPurgeJob.doJob(OutgoingPurgeJob.java:49)
    at org.jumpmind.symmetric.job.AbstractJob.invoke(AbstractJob.java:227)
    at org.jumpmind.symmetric.job.AbstractJob.run(AbstractJob.java:298)
    at org.springframework.scheduling.support.DelegatingErrorHandlingRunnable.run(DelegatingErrorHandlingRunnable.java:54)
    at org.springframework.scheduling.concurrent.ReschedulingRunnable.run(ReschedulingRunnable.java:93)
    at java.util.concurrent.Executors$RunnableAdapter.call(Unknown Source)
    at java.util.concurrent.FutureTask.run(Unknown Source)
    at java.util.concurrent.ScheduledThreadPoolExecutor$ScheduledFutureTask.access$201(Unknown Source)
    at java.util.concurrent.ScheduledThreadPoolExecutor$ScheduledFutureTask.run(Unknown Source)
    at java.util.concurrent.ThreadPoolExecutor.runWorker(Unknown Source)
    at java.util.concurrent.ThreadPoolExecutor$Worker.run(Unknown Source)
    at java.lang.Thread.run(Unknown Source)
Caused by: com.microsoft.sqlserver.jdbc.SQLServerException: Invalid object name 'sym_data_event'.
    at com.microsoft.sqlserver.jdbc.SQLServerException.makeFromDatabaseError(SQLServerException.java:256)
    at com.microsoft.sqlserver.jdbc.SQLServerStatement.getNextResult(SQLServerStatement.java:1621)
    at com.microsoft.sqlserver.jdbc.SQLServerPreparedStatement.doExecutePreparedStatement(SQLServerPreparedStatement.java:592)
    at com.microsoft.sqlserver.jdbc.SQLServerPreparedStatement$PrepStmtExecCmd.doExecute(SQLServerPreparedStatement.java:522)
    at com.microsoft.sqlserver.jdbc.TDSCommand.execute(IOBuffer.java:7194)
    at com.microsoft.sqlserver.jdbc.SQLServerConnection.executeCommand(SQLServerConnection.java:2930)
    at com.microsoft.sqlserver.jdbc.SQLServerStatement.executeCommand(SQLServerStatement.java:248)
    at com.microsoft.sqlserver.jdbc.SQLServerStatement.executeStatement(SQLServerStatement.java:223)
    at com.microsoft.sqlserver.jdbc.SQLServerPreparedStatement.execute(SQLServerPreparedStatement.java:503)
    at org.apache.commons.dbcp.DelegatingPreparedStatement.execute(DelegatingPreparedStatement.java:172)
    at org.apache.commons.dbcp.DelegatingPreparedStatement.execute(DelegatingPreparedStatement.java:172)
    at org.jumpmind.db.sql.JdbcSqlTemplate$5.execute(JdbcSqlTemplate.java:395)
    at org.jumpmind.db.sql.JdbcSqlTemplate$5.execute(JdbcSqlTemplate.java:358)
    at org.jumpmind.db.sql.JdbcSqlTemplate.execute(JdbcSqlTemplate.java:517)
    ... 16 more
Tagspurge

Activities

elong

2019-11-26 19:47

developer   ~0001656

Thanks for reporting. Will try to release 3.11.1 by end of week.

Related Changesets

SymmetricDS: 3.11 e5a6c0e5

2019-11-26 19:46:26

admin

Details Diff
0004166: Purge not working when using prefix on sym tables.
0004166
mod - symmetric-core/src/main/java/org/jumpmind/symmetric/service/impl/PurgeServiceSqlMap.java Diff File

Issue History

Date Modified Username Field Change
2019-11-26 19:41 j.mackay@backinmotion.com.au New Issue
2019-11-26 19:46 elong Assigned To => elong
2019-11-26 19:46 elong Status new => assigned
2019-11-26 19:47 elong Status assigned => resolved
2019-11-26 19:47 elong Resolution open => fixed
2019-11-26 19:47 elong Fixed in Version => 3.11.1
2019-11-26 19:47 elong Note Added: 0001656
2019-11-26 19:48 elong Tag Attached: purge
2019-11-26 19:48 elong Target Version => 3.11.1
2019-11-26 19:48 elong Summary MSSQL: Purge not working when using prefix on sym tables. => Purge not working when using prefix on sym tables.
2019-11-26 20:00 admin Changeset attached => SymmetricDS 3.11 e5a6c0e5
2019-12-02 15:12 admin Status resolved => closed