View Issue Details

IDProjectCategoryView StatusLast Update
0004187SymmetricDSImprovementpublic2019-12-09 12:27
ReporterelongAssigned Toelong 
Prioritynormal 
Status closedResolutionfixed 
Product Version3.11.0 
Target Version3.11.2Fixed in Version3.11.2 
Summary0004187: Initial load queue and router service blocking each other
DescriptionThe initial load service and router service both acquire batch sequence numbers. Sequence numbers should always commit immediately to prevent blocking the other service.

2019-12-06 09:46:51,900 ERROR [server] [InitialLoadService] [server-job-9] Error while queuing initial loads (org.jumpmind.symmetric.service.impl.InitialLoadService.queueLoads(InitialLoadService.java:99))
org.jumpmind.db.sql.SqlException: Lock wait timeout exceeded; try restarting transaction
    at org.jumpmind.db.sql.AbstractSqlTemplate.translate(AbstractSqlTemplate.java:305)
    at org.jumpmind.db.sql.AbstractSqlTemplate.translate(AbstractSqlTemplate.java:294)
    at org.jumpmind.db.sql.JdbcSqlTransaction.executeCallback(JdbcSqlTransaction.java:398)
    at org.jumpmind.db.sql.JdbcSqlTransaction.prepareAndExecute(JdbcSqlTransaction.java:364)
    at org.jumpmind.symmetric.service.impl.SequenceService.tryToGetNextVal(SequenceService.java:182)
    at org.jumpmind.symmetric.service.impl.SequenceService.nextValFromDatabase(SequenceService.java:141)
    at org.jumpmind.symmetric.service.impl.SequenceService$2.execute(SequenceService.java:128)
    at org.jumpmind.symmetric.service.impl.SequenceService$2.execute(SequenceService.java:1)
    at org.jumpmind.symmetric.service.impl.SequenceService$DoTransaction.execute(SequenceService.java:355)
    at org.jumpmind.symmetric.service.impl.SequenceService.nextValFromDatabase(SequenceService.java:130)
    at org.jumpmind.symmetric.service.impl.SequenceService.nextRange(SequenceService.java:237)
    at org.jumpmind.symmetric.service.impl.DataService.insertRequestedOutgoingBatches(DataService.java:689)
    at org.jumpmind.symmetric.service.impl.DataService.insertLoadBatchesForReload(DataService.java:1523)
    at org.jumpmind.symmetric.service.impl.DataService.insertReloadEvents(DataService.java:980)
    at org.jumpmind.symmetric.service.impl.InitialLoadService.processTableRequestLoads(InitialLoadService.java:225)
    at org.jumpmind.symmetric.service.impl.InitialLoadService.queueLoads(InitialLoadService.java:93)
    at org.jumpmind.symmetric.job.InitialLoadJob.doJob(InitialLoadJob.java:43)
    at org.jumpmind.symmetric.job.AbstractJob.invoke(AbstractJob.java:227)
    at org.jumpmind.symmetric.job.AbstractJob.run(AbstractJob.java:298)
    at org.springframework.scheduling.support.DelegatingErrorHandlingRunnable.run(DelegatingErrorHandlingRunnable.java:54)
    at java.util.concurrent.Executors$RunnableAdapter.call(Executors.java:511)
    at java.util.concurrent.FutureTask.runAndReset(FutureTask.java:308)
    at java.util.concurrent.ScheduledThreadPoolExecutor$ScheduledFutureTask.access$301(ScheduledThreadPoolExecutor.java:180)
    at java.util.concurrent.ScheduledThreadPoolExecutor$ScheduledFutureTask.run(ScheduledThreadPoolExecutor.java:294)
    at java.util.concurrent.ThreadPoolExecutor.runWorker(ThreadPoolExecutor.java:1149)
    at java.util.concurrent.ThreadPoolExecutor$Worker.run(ThreadPoolExecutor.java:624)
    at java.lang.Thread.run(Thread.java:748)
Caused by: com.mysql.jdbc.exceptions.jdbc4.MySQLTransactionRollbackException: Lock wait timeout exceeded; try restarting transaction
    at sun.reflect.NativeConstructorAccessorImpl.newInstance0(Native Method)
    at sun.reflect.NativeConstructorAccessorImpl.newInstance(NativeConstructorAccessorImpl.java:62)
    at sun.reflect.DelegatingConstructorAccessorImpl.newInstance(DelegatingConstructorAccessorImpl.java:45)
    at java.lang.reflect.Constructor.newInstance(Constructor.java:423)
    at com.mysql.jdbc.Util.handleNewInstance(Util.java:425)
    at com.mysql.jdbc.Util.getInstance(Util.java:408)
    at com.mysql.jdbc.SQLError.createSQLException(SQLError.java:952)
    at com.mysql.jdbc.MysqlIO.checkErrorPacket(MysqlIO.java:3973)
    at com.mysql.jdbc.MysqlIO.checkErrorPacket(MysqlIO.java:3909)
    at com.mysql.jdbc.MysqlIO.sendCommand(MysqlIO.java:2527)
    at com.mysql.jdbc.MysqlIO.sqlQueryDirect(MysqlIO.java:2680)
    at com.mysql.jdbc.ConnectionImpl.execSQL(ConnectionImpl.java:2484)
    at com.mysql.jdbc.PreparedStatement.executeInternal(PreparedStatement.java:1858)
    at com.mysql.jdbc.PreparedStatement.execute(PreparedStatement.java:1197)
    at org.apache.commons.dbcp.DelegatingPreparedStatement.execute(DelegatingPreparedStatement.java:172)
    at org.apache.commons.dbcp.DelegatingPreparedStatement.execute(DelegatingPreparedStatement.java:172)
    at org.jumpmind.db.sql.JdbcSqlTransaction$6.execute(JdbcSqlTransaction.java:374)
    at org.jumpmind.db.sql.JdbcSqlTransaction$6.execute(JdbcSqlTransaction.java:1)
    at org.jumpmind.db.sql.JdbcSqlTransaction.executeCallback(JdbcSqlTransaction.java:396)
    ... 24 more
Tagsinitial/partial load

Activities

There are no notes attached to this issue.

Related Changesets

SymmetricDS: 3.11 f1de1c30

2019-12-06 09:59:34

admin

Details Diff
0004187: Initial load queue and router service blocking each other
0004187
mod - symmetric-core/src/main/java/org/jumpmind/symmetric/service/impl/InitialLoadService.java Diff File
mod - symmetric-core/src/main/java/org/jumpmind/symmetric/service/impl/OutgoingBatchService.java Diff File

SymmetricDS: 3.11 3679cf96

2019-12-06 10:57:04

admin

Details Diff
0004187: Initial load queue and router service blocking each other
0004187
mod - symmetric-core/src/main/java/org/jumpmind/symmetric/service/ISequenceService.java Diff File
mod - symmetric-core/src/main/java/org/jumpmind/symmetric/service/impl/DataService.java Diff File
mod - symmetric-core/src/main/java/org/jumpmind/symmetric/service/impl/SequenceService.java Diff File

SymmetricDS: 3.11 27a33d32

2019-12-09 10:13:44

admin

Details Diff
0004187: Initial load queue and router service blocking each other
0004187
mod - symmetric-core/src/main/java/org/jumpmind/symmetric/service/impl/OutgoingBatchService.java Diff File

Issue History

Date Modified Username Field Change
2019-12-06 09:49 elong New Issue
2019-12-06 09:49 elong Status new => assigned
2019-12-06 09:49 elong Assigned To => elong
2019-12-06 09:49 elong Tag Attached: initial/partial load
2019-12-06 10:00 admin Changeset attached => SymmetricDS 3.11 f1de1c30
2019-12-06 10:00 elong Status assigned => resolved
2019-12-06 10:00 elong Resolution open => fixed
2019-12-06 10:00 elong Fixed in Version => 3.11.2
2019-12-06 11:00 admin Changeset attached => SymmetricDS 3.11 3679cf96
2019-12-09 11:00 admin Changeset attached => SymmetricDS 3.11 27a33d32
2019-12-09 12:27 admin Status resolved => closed