View Issue Details

IDProjectCategoryView StatusLast Update
0001030SymmetricDSBugpublic2014-02-02 20:53
Reporterraja_s_patilAssigned Tochenson 
PriorityhighSeveritymajorReproducibilityalways
Status closedResolutionfixed 
Product Version3.2.1 
Target Version3.3.0Fixed in Version3.3.0 
Summary0001030: Exception in clustered firebird environment
DescriptionDatabase at Both ends is Firebird 2.1 (64 bit Linux)
Tomcat 7.0.29 deployment. Only HO Config being Tested in Clustered Environment.
Tomcat being run in Three Instances on same machine.

The config files and Log Files are attached herewith. It seems that Firebird Dialect is not honoring SYM_LOCK entries.
  
TagsNo tags attached.

Activities

raja_s_patil

2013-02-03 06:05

reporter  

Cluster-Test.rar (9,820 bytes)

chenson

2013-02-03 09:46

administrator   ~0000212

The error is ugly in the log files, but doesn't cause any damage does it?

raja_s_patil

2013-02-03 10:16

reporter   ~0000213

It Might have but I have not checked, since its a Test Database with almost nil Data, may be 10 to 20 records just used to see how replication in clustering takes place. More ever its only HO database which is not connected to any branch Database since we wanted test to be less complicated in initial stages. I had posted this issue on Forum too but it was not answered. We were not planning any clustering immediately so it was not pressed much. We expect production level clustering requirement after at least 2/3 months so we have ample time to resolve this issue.

chenson

2013-02-03 10:19

administrator   ~0000214

It doesn't look like it will hurt anything. I'll catch it and return a status back to the caller that the lock was not grabbed.

Related Changesets

SymmetricDS: master 53cbcbad

2013-02-03 10:44:50

chenson

Details Diff
0001030: Exception in clustered environment
0001030
mod - symmetric-core/src/main/java/org/jumpmind/symmetric/service/impl/ClusterService.java Diff File
add - symmetric-db/src/main/java/org/jumpmind/db/sql/ConcurrencySqlException.java Diff File
mod - symmetric-jdbc/src/main/java/org/jumpmind/db/platform/firebird/FirebirdJdbcSqlTemplate.java Diff File

Issue History

Date Modified Username Field Change
2013-02-03 06:05 raja_s_patil New Issue
2013-02-03 06:05 raja_s_patil File Added: Cluster-Test.rar
2013-02-03 09:46 chenson Note Added: 0000212
2013-02-03 10:16 raja_s_patil Note Added: 0000213
2013-02-03 10:19 chenson Note Added: 0000214
2013-02-03 10:45 chenson Fixed in Version => 3.3.0
2013-02-03 10:45 chenson Target Version => 3.3.0
2013-02-03 10:45 chenson Status new => resolved
2013-02-03 10:45 chenson Resolution open => fixed
2013-02-03 10:45 chenson Assigned To => chenson
2013-02-04 15:47 chenson Summary Exception in clustered environment => Exception in clustered firebird environment
2013-02-06 19:05 chenson Status resolved => closed
2014-02-02 20:53 Changeset attached => SymmetricDS trunk r6824
2015-07-30 21:49 chenson Changeset attached => SymmetricDS master 53cbcbad