View Issue Details

IDProjectCategoryView StatusLast Update
0001054SymmetricDS ProImprovementpublic2013-04-21 10:08
ReporterabrougherAssigned Tochenson 
PrioritylowSeverityminorReproducibilityalways
Status closedResolutionfixed 
Product Version3.3.1 
Target Version3.4.0Fixed in Version3.4.0 
Summary0001054: Trigger edit panel table rows scroll around after a user cancels an edit.
DescriptionOn the configure trigger screen, if the number of trigger records exceeds the length of the table, the scroll bar is moved after the user edits and cancels editing a trigger.

This happens because we reload the table, and lose the users scroll position once the table is refreshed. To compensate, we scroll down so the last edited row is the first row displayed in the table.

It looks like we refresh the table today because we are not calling discard on the form. By calling refresh we reload all of the bean items so only the committed changes show back up. If we discard the form changes we can avoid calling refresh and losing the scroll position.
TagsNo tags attached.

Activities

There are no notes attached to this issue.

Issue History

Date Modified Username Field Change
2013-02-20 16:36 abrougher New Issue
2013-02-20 16:36 abrougher Status new => assigned
2013-02-20 16:36 abrougher Assigned To => abrougher
2013-03-05 23:11 abrougher Status assigned => resolved
2013-03-05 23:11 abrougher Fixed in Version => 3.4.0
2013-03-05 23:11 abrougher Resolution open => fixed
2013-03-05 23:11 abrougher Assigned To abrougher => chenson
2013-04-21 10:08 chenson Status resolved => closed