View Issue Details

IDProjectCategoryView StatusLast Update
0001066SymmetricDSBugpublic2014-02-02 20:53
ReportergwilmerAssigned Tochenson 
PrioritynormalSeveritymajorReproducibilitysometimes
Status closedResolutionfixed 
Product Version3.3.1 
Target Version3.3.2Fixed in Version3.3.2 
Summary0001066: Reverse initial load may be computed and routed before triggers are done synchronizing when a client first registers
DescriptionSometimes when a client is set to reverse initial load, the client will actually compute and route a portion of the reverse initial load before triggers are done synchronizing on the client. The end result may be the partial reverse initial load failing due to foreign key constraints.

1. Client reaches out to register with reg server
2. Client gets profile from reg server
3. Client begins to sync triggers
4. Reverse initial load begins routing before sync triggers is complete thus using a subset of tables for the reverse initial load
5. Ordering of those subset of tables is correct for the subset but incorrect for the whole (missing dependencies for the triggers/tables that were not yet synchronized at the time routing kicked off.
6. Reverse initial load batches fail on target due to foreign key constraints
7. Full reverse initial load is kicked off again after registration and sync triggers is complete, but is backed up behind failed batches from 0000006.
TagsNo tags attached.

Activities

There are no notes attached to this issue.

Related Changesets

SymmetricDS: master 0231c226

2013-02-24 11:29:21

chenson

Details Diff
0001066: Reverse initial load may be computed and routed before triggers are done synchronizing when a client first registers
0001066
mod - symmetric-core/src/main/java/org/jumpmind/symmetric/service/impl/RouterService.java Diff File

Issue History

Date Modified Username Field Change
2013-02-23 07:43 gwilmer New Issue
2013-02-23 08:47 chenson Assigned To => chenson
2013-02-23 08:47 chenson Status new => assigned
2013-02-24 11:29 chenson Status assigned => resolved
2013-02-24 11:29 chenson Fixed in Version => 3.3.2
2013-02-24 11:29 chenson Resolution open => fixed
2013-02-26 07:56 chenson Status resolved => closed
2014-02-02 20:53 Changeset attached => SymmetricDS trunk r6884
2015-07-30 21:49 chenson Changeset attached => SymmetricDS master 0231c226