View Issue Details

IDProjectCategoryView StatusLast Update
0001101SymmetricDSBugpublic2014-02-02 20:53
ReporterchensonAssigned Tochenson 
PrioritynormalSeverityminorReproducibilityhave not tried
Status closedResolutionfixed 
Product Version3.3.3 
Target Version3.3.4Fixed in Version3.3.4 
Summary0001101: sqlite create tables doesn't work because a transaction is in process and the database is locked
Descriptionsqlite create tables doesn't work because a transaction is in process and the database is locked
TagsNo tags attached.

Activities

There are no notes attached to this issue.

Related Changesets

SymmetricDS: master 87956946

2013-03-08 08:06:44

chenson

Details Diff
0001101: sqlite create tables doesn't work because a transaction is in process and the database is locked
0001100: sqlite create tables quotes create_timestamp default values

0001101
mod - symmetric-core/src/main/java/org/jumpmind/symmetric/service/impl/NodeService.java Diff File
mod - symmetric-db/src/main/java/org/jumpmind/db/platform/AbstractDdlBuilder.java Diff File
mod - symmetric-db/src/main/java/org/jumpmind/db/platform/h2/H2DdlBuilder.java Diff File
mod - symmetric-db/src/main/java/org/jumpmind/db/platform/mysql/MySqlDdlBuilder.java Diff File
mod - symmetric-db/src/main/java/org/jumpmind/db/platform/oracle/OracleDdlBuilder.java Diff File
mod - symmetric-db/src/main/java/org/jumpmind/db/platform/sqlite/SqliteDdlBuilder.java Diff File
mod - symmetric-io/src/main/java/org/jumpmind/symmetric/io/data/writer/DatabaseWriter.java Diff File

Issue History

Date Modified Username Field Change
2013-03-07 20:46 chenson New Issue
2013-03-07 20:46 chenson Status new => assigned
2013-03-07 20:46 chenson Assigned To => chenson
2013-03-08 08:05 chenson Status assigned => resolved
2013-03-08 08:05 chenson Fixed in Version => 3.3.4
2013-03-08 08:05 chenson Resolution open => fixed
2013-03-09 12:25 chenson Status resolved => closed
2014-02-02 20:53 Changeset attached => SymmetricDS trunk r6930
2014-02-02 20:53 Changeset attached => SymmetricDS 3.3 r6931
2015-07-30 21:49 chenson Changeset attached => SymmetricDS master 87956946