View Issue Details

IDProjectCategoryView StatusLast Update
0001133SymmetricDSBugpublic2014-02-02 20:53
ReporterchensonAssigned Tochenson 
PrioritynormalSeverityminorReproducibilityhave not tried
Status closedResolutionfixed 
Product Version3.3.5 
Target Version3.3.6Fixed in Version3.3.6 
Summary0001133: Multiple reverse reloads can be queued up because of timing issues
DescriptionWhen reverse_initial_load_enabled is set during registration an update is captured and sync'd to the client. If the time is just right the client can queue up a reverse initial load, set reverse_initial_load_enabled=0 and then the update syncs down and sets it back to 1 at which time another reverse initial load is queued up.
TagsNo tags attached.

Activities

chenson

2013-04-03 07:53

administrator   ~0000243

Ready for release

Related Changesets

SymmetricDS: master 41b04301

2013-03-22 12:29:33

chenson

Details Diff
0001133: Multiple reverse reloads can be queued up because of timing issues
0001133
mod - symmetric-core/src/main/java/org/jumpmind/symmetric/service/impl/RegistrationService.java Diff File

SymmetricDS: master 05d16e7d

2013-03-28 15:25:55

chenson

Details Diff
0001133: Multiple reverse reloads can be queued up because of timing issues
0001133
mod - symmetric-core/src/main/java/org/jumpmind/symmetric/service/impl/RegistrationService.java Diff File

SymmetricDS: master 34fe0bce

2013-03-28 16:26:06

chenson

Details Diff
0001133: Multiple reverse reloads can be queued up because of timing issues
0001133
mod - symmetric-core/src/main/java/org/jumpmind/symmetric/service/INodeService.java Diff File
mod - symmetric-core/src/main/java/org/jumpmind/symmetric/service/impl/DataService.java Diff File
mod - symmetric-core/src/main/java/org/jumpmind/symmetric/service/impl/NodeService.java Diff File
mod - symmetric-core/src/main/java/org/jumpmind/symmetric/service/impl/RegistrationService.java Diff File
mod - symmetric-core/src/test/java/org/jumpmind/symmetric/service/impl/MockNodeService.java Diff File

Issue History

Date Modified Username Field Change
2013-03-22 12:27 chenson New Issue
2013-03-22 12:27 chenson Status new => assigned
2013-03-22 12:27 chenson Assigned To => chenson
2013-03-25 20:14 chenson Status assigned => resolved
2013-03-25 20:14 chenson Fixed in Version => 3.3.6
2013-03-25 20:14 chenson Resolution open => fixed
2013-04-03 07:53 chenson Note Added: 0000243
2013-04-03 07:53 chenson Status resolved => closed
2014-02-02 20:53 Changeset attached => SymmetricDS trunk r6997
2014-02-02 20:53 Changeset attached => SymmetricDS 3.3 r7013
2014-02-02 20:53 Changeset attached => SymmetricDS trunk r7014
2014-02-02 20:53 Changeset attached => SymmetricDS 3.3 r7016
2014-02-02 20:53 Changeset attached => SymmetricDS trunk r7017
2015-07-30 21:49 chenson Changeset attached => SymmetricDS master 34fe0bce
2015-07-30 21:49 chenson Changeset attached => SymmetricDS master 05d16e7d
2015-07-30 21:49 chenson Changeset attached => SymmetricDS master 41b04301