View Issue Details

IDProjectCategoryView StatusLast Update
0001217SymmetricDS ProImprovementpublic2014-02-02 20:53
ReportergwilmerAssigned Toabrougher 
PrioritynormalSeverityminorReproducibilityalways
Status closedResolutionfixed 
Product Version3.4.4 
Target Version3.4.5Fixed in Version3.4.5 
Summary0001217: Don't allow node group link delete until transforms using that link are also removed.
DescriptionDelete button on node group link is enabled even through there are transforms that exist that still use the node group link. This causes a referential integrity constraint to fire, and the node group can't be deleted.

We should disable the node group delete button in this case. Would be even better to show them WHY they can't remove the node group link, due to tranform, router, etc.
TagsNo tags attached.

Activities

There are no notes attached to this issue.

Related Changesets

SymmetricDS: master 8d34ed2d

2013-05-15 18:17:54

abrougher

Details Diff
0001217: Don't allow node group link delete until transforms using that link are also removed.
0001217
mod - symmetric-core/src/main/java/org/jumpmind/symmetric/service/impl/TransformService.java Diff File

Issue History

Date Modified Username Field Change
2013-05-15 10:42 gwilmer New Issue
2013-05-15 11:06 chenson Assigned To => abrougher
2013-05-15 11:06 chenson Status new => assigned
2013-05-15 18:44 chenson Product Version 3.5.0 => 3.4.4
2013-05-15 18:44 chenson Fixed in Version => 3.4.5
2013-05-15 18:44 chenson Target Version => 3.4.5
2013-05-15 18:45 chenson Status assigned => resolved
2013-05-15 18:45 chenson Resolution open => fixed
2013-05-29 21:13 chenson Status resolved => closed
2014-02-02 20:53 abrougher Changeset attached => SymmetricDS trunk r7206
2014-02-02 20:53 Changeset attached => SymmetricDS 3.4 r7214
2015-07-30 21:49 abrougher Changeset attached => SymmetricDS master 8d34ed2d