View Issue Details

IDProjectCategoryView StatusLast Update
0001279SymmetricDSBugpublic2019-05-08 10:56
ReporterSektatAssigned Toelong 
Prioritynormal 
Status closedResolutionfixed 
Product Version3.4.6 
Target VersionFixed in Version3.10.2 
Summary0001279: Derby - clob - primary key (date)
DescriptionIf I want to replicate a (derby 10.9.1.0) store transaction data table like this (removed non-important columns):

create table pos_journal_transaction (
  evt_day date not null,
  receipt_data clob(64K));

Primary key = EVT_DAY

I receive this error as soon as I insert data into the table

java.sql.SQLException: The syntax of the string representation of a datetime value is incorrect.

After logging all SQL statements I found this statement generated by the symetrics code:

select RECEIPT_DATA from pos_journal_transaction
where "EVT_DAY"={ts '2013-06-14'}

This seems to be the cause for the errormessage (reproducable), since evt_day is a date and therefore the jdbc escape syntax for date must be used, which is a "d".
Correct would be:
select RECEIPT_DATA from pos_journal_transaction
where "EVT_DAY"={d '2013-06-14'}

If I ignore the receipt_data column (sym_trigger.exclude_column='receipt_data'), everything works fine, as expected.
Steps To Reproducesee above.
Tagsdata sync, dialect: derby

Activities

elong

2019-04-26 16:17

developer   ~0001450

Confirmed that I get the error after installing the SymmetricDS trigger.

create table pos_journal_transaction (evt_day date not null primary key, receipt_data clob(64K));

insert into pos_journal_transaction values ({d '2019-04-01'}, null);

SQL Message: The exception 'java.sql.SQLDataException: The syntax of the string representation of a date/time value is incorrect.' was thrown while evaluating an expression.
SQL State: 38000
Error Code: 20000

Related Changesets

SymmetricDS: 3.10 85a80d66

2019-04-26 16:18:40

admin

Details Diff
0001279: Derby - clob - primary key (date)
0001279
mod - symmetric-client/src/main/java/org/jumpmind/symmetric/db/derby/DerbyFunctions.java Diff File

Issue History

Date Modified Username Field Change
2013-06-14 09:45 Sektat New Issue
2019-04-22 09:17 elong Tag Attached: data sync
2019-04-22 09:18 elong Tag Attached: Apache Derby
2019-04-23 16:43 admin Tag Renamed Apache Derby => dialect: derby
2019-04-26 16:17 elong Assigned To => elong
2019-04-26 16:17 elong Status new => confirmed
2019-04-26 16:17 elong Note Added: 0001450
2019-04-26 16:20 elong Status confirmed => resolved
2019-04-26 16:20 elong Resolution open => fixed
2019-04-26 16:20 elong Fixed in Version => 3.10.2
2019-04-26 17:00 admin Changeset attached => SymmetricDS 3.10 85a80d66
2019-05-08 10:56 admin Status resolved => closed