View Issue Details

IDProjectCategoryView StatusLast Update
0001611SymmetricDS ProBugpublic2019-06-25 14:20
ReporterelongAssigned Toelong 
Priorityhigh 
Status closedResolutionfixed 
Product Version3.5.0 
Target Version3.9.21Fixed in Version3.9.21 
Summary0001611: Support snapshot fails when database does not exist
DescriptionFeb 28, 2014 3:33:08 PM com.vaadin.Application terminalError
SEVERE: Terminal error:
com.vaadin.event.ListenerMethod$MethodException: Invocation of method
buttonClick in com.jumpmind.symmetric.console.ui.screen.b.c$2 failed.
         at
com.vaadin.event.ListenerMethod.receiveEvent(ListenerMethod.java:530)
         at com.vaadin.event.EventRouter.fireEvent(EventRouter.java:164)
         at
com.vaadin.ui.AbstractComponent.fireEvent(AbstractComponent.java:1219)
         at com.vaadin.ui.Button.fireClick(Button.java:567)
         at com.vaadin.ui.Button.changeVariables(Button.java:223)
         at
com.vaadin.terminal.gwt.server.AbstractCommunicationManager.changeVariables(AbstractCommunicationManager.java:1460)
         at
com.vaadin.terminal.gwt.server.AbstractCommunicationManager.handleVariableBurst(AbstractCommunicationManager.java:1404)
         at
com.vaadin.terminal.gwt.server.AbstractCommunicationManager.handleVariables(AbstractCommunicationManager.java:1329)
         at
com.vaadin.terminal.gwt.server.AbstractCommunicationManager.doHandleUidlRequest(AbstractCommunicationManager.java:761)
         at
com.vaadin.terminal.gwt.server.CommunicationManager.handleUidlRequest(CommunicationManager.java:325)
         at
com.vaadin.terminal.gwt.server.AbstractApplicationServlet.service(AbstractApplicationServlet.java:501)
         at javax.servlet.http.HttpServlet.service(HttpServlet.java:820)
         at
org.eclipse.jetty.servlet.ServletHolder.handle(ServletHolder.java:565)
         at
org.eclipse.jetty.servlet.ServletHandler.doHandle(ServletHandler.java:479)
         at
org.eclipse.jetty.server.handler.ScopedHandler.handle(ScopedHandler.java:119)
         at
org.eclipse.jetty.security.SecurityHandler.handle(SecurityHandler.java:524)
         at
org.eclipse.jetty.server.session.SessionHandler.doHandle(SessionHandler.java:227)
         at
org.eclipse.jetty.server.handler.ContextHandler.doHandle(ContextHandler.java:1031)
         at
org.eclipse.jetty.servlet.ServletHandler.doScope(ServletHandler.java:406)
         at
org.eclipse.jetty.server.session.SessionHandler.doScope(SessionHandler.java:186)
         at
org.eclipse.jetty.server.handler.ContextHandler.doScope(ContextHandler.java:965)
         at
org.eclipse.jetty.server.handler.ScopedHandler.handle(ScopedHandler.java:117)
         at
org.eclipse.jetty.server.handler.HandlerWrapper.handle(HandlerWrapper.java:111)
         at org.eclipse.jetty.server.Server.handle(Server.java:348)
         at
org.eclipse.jetty.server.AbstractHttpConnection.handleRequest(AbstractHttpConnection.java:452)
         at
org.eclipse.jetty.server.AbstractHttpConnection.content(AbstractHttpConnection.java:894)
         at
org.eclipse.jetty.server.AbstractHttpConnection$RequestHandler.content(AbstractHttpConnection.java:948)
         at org.eclipse.jetty.http.HttpParser.parseNext(HttpParser.java:851)
         at
org.eclipse.jetty.http.HttpParser.parseAvailable(HttpParser.java:230)

         at
org.eclipse.jetty.server.AsyncHttpConnection.handle(AsyncHttpConnection.java:77)
         at
org.eclipse.jetty.io.nio.SelectChannelEndPoint.handle(SelectChannelEndPoint.java:606)
         at
org.eclipse.jetty.io.nio.SelectChannelEndPoint$1.run(SelectChannelEndPoint.java:46)
         at
org.eclipse.jetty.util.thread.QueuedThreadPool.runJob(QueuedThreadPool.java:603)
         at
org.eclipse.jetty.util.thread.QueuedThreadPool$3.run(QueuedThreadPool.java:538)
         at java.lang.Thread.run(Unknown Source)
         Caused by: org.jumpmind.db.sql.SqlException: La base de datos
'ASPTESTEDI' no existe. Aseg├║rese de que ha escrito el nombre correctamente.
         at
org.jumpmind.db.sql.AbstractSqlTemplate.translate(AbstractSqlTemplate.java:288)
         at
org.jumpmind.db.sql.AbstractSqlTemplate.translate(AbstractSqlTemplate.java:279)
         at
org.jumpmind.db.sql.JdbcSqlTemplate.execute(JdbcSqlTemplate.java:417)

         at
org.jumpmind.db.platform.AbstractJdbcDdlReader.readTable(AbstractJdbcDdlReader.java:543)
         at
org.jumpmind.db.platform.AbstractDatabasePlatform.readTableFromDatabase(AbstractDatabasePlatform.java:233)
         at
org.jumpmind.db.platform.AbstractDatabasePlatform.getTableFromCache(AbstractDatabasePlatform.java:312)
         at
org.jumpmind.symmetric.util.SnapshotUtil.createSnapshot(SnapshotUtil.java:93)
         at
org.jumpmind.symmetric.ClientSymmetricEngine.snapshot(ClientSymmetricEngine.java:386)
         at
com.jumpmind.symmetric.console.ui.screen.b.c$2.buttonClick(SupportPanel.java:55)
         at sun.reflect.GeneratedMethodAccessor86.invoke(Unknown Source)
         at sun.reflect.DelegatingMethodAccessorImpl.invoke(Unknown Source)
         at java.lang.reflect.Method.invoke(Unknown Source)
         at
com.vaadin.event.ListenerMethod.receiveEvent(ListenerMethod.java:510)

         ... 34 more
         Caused by: java.sql.SQLException: La base de datos 'ASPTESTEBI'
no existe. Asegrese de que ha escrito el nombre correctamente.(Javier
say: The DB 'ASPTESTEBI' exist)
         at
net.sourceforge.jtds.jdbc.SQLDiagnostic.addDiagnostic(SQLDiagnostic.java:368)
         at
net.sourceforge.jtds.jdbc.TdsCore.tdsErrorToken(TdsCore.java:2820)
         at net.sourceforge.jtds.jdbc.TdsCore.nextToken(TdsCore.java:2258)
         at
net.sourceforge.jtds.jdbc.TdsCore.getMoreResults(TdsCore.java:632)
         at
net.sourceforge.jtds.jdbc.MSCursorResultSet.processOutput(MSCursorResultSet.java:943)
         at
net.sourceforge.jtds.jdbc.MSCursorResultSet.cursorCreate(MSCursorResultSet.java:541)
         at
net.sourceforge.jtds.jdbc.MSCursorResultSet.<init>(MSCursorResultSet.java:154)
         at
net.sourceforge.jtds.jdbc.JtdsStatement.executeSQLQuery(JtdsStatement.java:424)
         at
net.sourceforge.jtds.jdbc.JtdsPreparedStatement.executeQuery(JtdsPreparedStatement.java:781)
         at
net.sourceforge.jtds.jdbc.JtdsDatabaseMetaData.getTables(JtdsDatabaseMetaData.java:1831)
         at
org.apache.commons.dbcp.DelegatingDatabaseMetaData.getTables(DelegatingDatabaseMetaData.java:604)
         at
org.jumpmind.db.platform.DatabaseMetaDataWrapper.getTables(DatabaseMetaDataWrapper.java:130)
         at
org.jumpmind.db.platform.AbstractJdbcDdlReader$3.execute(AbstractJdbcDdlReader.java:553)
         at
org.jumpmind.db.platform.AbstractJdbcDdlReader$3.execute(AbstractJdbcDdlReader.java:543)
         at
org.jumpmind.db.sql.JdbcSqlTemplate.execute(JdbcSqlTemplate.java:415)
Tagsdialect: sql-server

Activities

elong

2019-04-29 08:29

developer   ~0001452

Is this for SQL-Server because it tries to switch to the database to read metadata?

Related Changesets

SymmetricDS: 3.9 28900c84

2019-05-20 16:39:47

admin

Details Diff
0001611: Support snapshot fails when database does not exist
0001611
mod - symmetric-client/src/main/java/org/jumpmind/symmetric/util/SnapshotUtil.java Diff File

SymmetricDS: 3.10 bd949bc2

2019-05-20 16:39:47

admin

Details Diff
0001611: Support snapshot fails when database does not exist
0001611
mod - symmetric-client/src/main/java/org/jumpmind/symmetric/util/SnapshotUtil.java Diff File

Issue History

Date Modified Username Field Change
2014-02-28 14:02 elong New Issue
2019-04-29 08:29 elong Note Added: 0001452
2019-05-09 10:18 admin Tag Attached: dialect: sql-server
2019-05-09 10:19 admin Priority normal => high
2019-05-09 10:19 admin Status new => confirmed
2019-05-09 13:19 elong Target Version => 3.10.3
2019-05-20 16:44 elong Assigned To => elong
2019-05-20 16:44 elong Status confirmed => resolved
2019-05-20 16:44 elong Resolution open => fixed
2019-05-20 16:44 elong Fixed in Version => 3.9.21
2019-05-20 16:44 elong Target Version 3.10.3 => 3.9.21
2019-05-20 17:00 admin Changeset attached => SymmetricDS 3.9 28900c84
2019-05-20 17:00 admin Changeset attached => SymmetricDS 3.10 bd949bc2
2019-06-25 14:20 admin Status resolved => closed