View Issue Details

IDProjectCategoryView StatusLast Update
0001760SymmetricDSImprovementpublic2014-06-16 20:27
ReporterjoannaaAssigned Tochenson 
PrioritynormalSeveritytweakReproducibilityalways
Status closedResolutionfixed 
Product Version3.5.22 
Target Version3.6.0Fixed in Version3.6.0 
Summary0001760: increase channel_id size
DescriptionI've been working on a python script to discover, and auto configure symmetricds for some basic replication scenarios. When trying to auto generate unique channel_ids (usually based on table name) it often fails due to the current 20 char limit. Would it be possible to increase the default to say 64?
Steps To ReproduceTry to insert a row into the sym_channel table where channel_id > 20 chars.
TagsNo tags attached.

Activities

There are no notes attached to this issue.

Related Changesets

SymmetricDS: master 41829e85

2014-06-11 13:56:38

chenson

Details Diff
0001760: increase channel_id size
0001760
mod - symmetric-core/src/main/resources/symmetric-schema.xml Diff File

Issue History

Date Modified Username Field Change
2014-06-11 13:13 joannaa New Issue
2014-06-11 13:56 chenson Assigned To => chenson
2014-06-11 13:56 chenson Status new => assigned
2014-06-11 13:56 chenson Fixed in Version => 3.6.0
2014-06-11 13:56 chenson Target Version => 3.6.0
2014-06-11 13:57 chenson Status assigned => resolved
2014-06-11 13:57 chenson Resolution open => fixed
2014-06-11 14:00 Changeset attached => SymmetricDS trunk r8368
2014-06-16 20:27 chenson Status resolved => closed
2015-07-30 21:49 chenson Changeset attached => SymmetricDS master 41829e85