View Issue Details

IDProjectCategoryView StatusLast Update
0002020SymmetricDSBugpublic2015-01-06 17:27
ReporterdocalAssigned Tochenson 
PrioritynormalSeveritymajorReproducibilityalways
Status closedResolutionfixed 
Product Version3.6.7 
Target Version3.7.0Fixed in Version3.7.0 
Summary0002020: Log4j cannot be configured to send errors by email
DescriptionI'm using sample configuration, provided by task 0001561 (naturally, with properly configured appender's parameters) and I'm getting the following error on startup:

log4j:WARN Error during default initialization
java.lang.NoClassDefFoundError: javax/mail/internet/AddressException

See Additional Information for the stack trace.

Please check this StackOverflow article, I believe it might be relevant: http://stackoverflow.com/questions/4569687/classnotfoundexception-javax-mail-internet-addressexception-when-running-hiberna
Steps To Reproduce1. Uncomment both sections in conf/log4j.xml, that are related to sending errors by email
2. (Optional, not required to reproduce the problem) Adjust EMAIL appender's parameters.
3. Run any SymmetricDS binary, e.g. bin/symadmin

The process will exit with an error (see Additional Information).
Additional Informationlog4j:WARN Error during default initialization
java.lang.NoClassDefFoundError: javax/mail/internet/AddressException
        at java.lang.Class.getDeclaredConstructors0(Native Method)
        at java.lang.Class.privateGetDeclaredConstructors(Unknown Source)
        at java.lang.Class.getConstructor0(Unknown Source)
        at java.lang.Class.newInstance0(Unknown Source)
        at java.lang.Class.newInstance(Unknown Source)
        at org.apache.log4j.xml.DOMConfigurator.parseAppender(DOMConfigurator.java:247)
        at org.apache.log4j.xml.DOMConfigurator.findAppenderByName(DOMConfigurator.java:176)
        at org.apache.log4j.xml.DOMConfigurator.findAppenderByReference(DOMConfigurator.java:191)
        at org.apache.log4j.xml.DOMConfigurator.parseChildrenOfLoggerElement(DOMConfigurator.java:523)
        at org.apache.log4j.xml.DOMConfigurator.parseRoot(DOMConfigurator.java:492)
        at org.apache.log4j.xml.DOMConfigurator.parse(DOMConfigurator.java:1001)
        at org.apache.log4j.xml.DOMConfigurator.doConfigure(DOMConfigurator.java:867)
        at org.apache.log4j.xml.DOMConfigurator.doConfigure(DOMConfigurator.java:773)
        at org.apache.log4j.helpers.OptionConverter.selectAndConfigure(OptionConverter.java:483)
        at org.apache.log4j.LogManager.<clinit>(LogManager.java:127)
        at org.slf4j.impl.Log4jLoggerFactory.getLogger(Log4jLoggerFactory.java:64)
        at org.slf4j.LoggerFactory.getLogger(LoggerFactory.java:253)
        at org.slf4j.LoggerFactory.getLogger(LoggerFactory.java:265)
        at org.jumpmind.symmetric.AbstractCommandLauncher.<clinit>(AbstractCommandLauncher.java:62)
Caused by: java.lang.ClassNotFoundException: javax.mail.internet.AddressException
        at java.net.URLClassLoader$1.run(Unknown Source)
        at java.security.AccessController.doPrivileged(Native Method)
        at java.net.URLClassLoader.findClass(Unknown Source)
        at java.lang.ClassLoader.loadClass(Unknown Source)
        at sun.misc.Launcher$AppClassLoader.loadClass(Unknown Source)
        at java.lang.ClassLoader.loadClass(Unknown Source)
        ... 19 more
TagsNo tags attached.

Activities

chenson

2014-10-22 16:10

administrator   ~0000591

Moving mail.jar from pro to open source.

Related Changesets

SymmetricDS: master 838dbc73

2014-10-22 16:10:18

chenson

Details Diff
0002020: Log4j cannot be configured to send errors by email
0002020
mod - symmetric-parent/pom.xml Diff File
mod - symmetric-server/pom.xml Diff File

Issue History

Date Modified Username Field Change
2014-10-22 12:40 docal New Issue
2014-10-22 16:10 chenson Note Added: 0000591
2014-10-22 16:10 chenson Assigned To => chenson
2014-10-22 16:10 chenson Status new => assigned
2014-10-22 16:10 chenson Fixed in Version => 3.7.0
2014-10-22 16:10 chenson Target Version => 3.7.0
2014-10-22 16:10 chenson Status assigned => resolved
2014-10-22 16:10 chenson Resolution open => fixed
2014-10-22 17:00 chenson Changeset attached => SymmetricDS trunk r8822
2015-01-06 17:27 chenson Status resolved => closed
2015-07-30 21:49 chenson Changeset attached => SymmetricDS master 838dbc73