View Issue Details

IDProjectCategoryView StatusLast Update
0002090SymmetricDSBugpublic2014-12-26 08:37
Reporterjosh-a-hicksAssigned Tochenson 
PrioritynormalSeverityminorReproducibilityhave not tried
Status closedResolutionfixed 
Product Version3.6.15 
Target Version3.6.17Fixed in Version3.6.17 
Summary0002090: Informix installations fail when existing SymmetricDS tables exist due to case sensitive comparisons
DescriptionWhen existing sym_* tables exist and a new node is connected where alters need to be performed they will throw a null pointer while comparing foreign keys due to a case sensitive comparison
TagsNo tags attached.

Activities

There are no notes attached to this issue.

Related Changesets

SymmetricDS: master 084353cf

2014-12-04 16:22:58

James

Details Diff
0002090 - Fix for Informix case sensitive ddl comparisons during sym_* table alterations.
0002090
mod - symmetric-jdbc/src/main/java/org/jumpmind/db/platform/informix/InformixJdbcSqlTemplate.java Diff File

SymmetricDS: master 7f99a29c

2014-12-12 13:18:02

chenson

Details Diff
0002090: Informix installations fail when existing SymmetricDS tables exist due to case sensitive comparisons
0002090
mod - symmetric-android/src/main/java/org/jumpmind/symmetric/android/AndroidSqlTransaction.java Diff File
mod - symmetric-client/src/main/java/org/jumpmind/symmetric/db/h2/H2SymmetricDialect.java Diff File
mod - symmetric-client/src/main/java/org/jumpmind/symmetric/io/MsSqlBulkDatabaseWriter.java Diff File
mod - symmetric-client/src/main/java/org/jumpmind/symmetric/io/MySqlBulkDatabaseWriter.java Diff File
mod - symmetric-client/src/main/java/org/jumpmind/symmetric/io/OracleBulkDatabaseWriter.java Diff File
mod - symmetric-client/src/main/java/org/jumpmind/symmetric/io/PostgresBulkDatabaseWriter.java Diff File
mod - symmetric-core/src/main/java/org/jumpmind/symmetric/load/DynamicDatabaseWriterFilter.java Diff File
mod - symmetric-core/src/main/java/org/jumpmind/symmetric/model/Trigger.java Diff File
mod - symmetric-core/src/main/java/org/jumpmind/symmetric/route/AuditTableDataRouter.java Diff File
mod - symmetric-core/src/main/java/org/jumpmind/symmetric/service/impl/ClusterService.java Diff File
mod - symmetric-core/src/main/java/org/jumpmind/symmetric/service/impl/DataService.java Diff File
mod - symmetric-core/src/main/resources/symmetric-schema.xml Diff File
mod - symmetric-core/src/test/java/org/jumpmind/symmetric/test/TestTablesService.java Diff File
mod - symmetric-db/src/main/java/org/jumpmind/db/model/Table.java Diff File
mod - symmetric-db/src/main/java/org/jumpmind/db/platform/AbstractDatabasePlatform.java Diff File
mod - symmetric-db/src/main/java/org/jumpmind/db/platform/AbstractDdlBuilder.java Diff File
mod - symmetric-db/src/main/java/org/jumpmind/db/platform/DatabaseInfo.java Diff File
mod - symmetric-db/src/main/java/org/jumpmind/db/platform/informix/InformixDdlBuilder.java Diff File
mod - symmetric-db/src/main/java/org/jumpmind/db/platform/mssql/MsSql2000DdlBuilder.java Diff File
mod - symmetric-db/src/main/java/org/jumpmind/db/sql/DmlStatement.java Diff File
mod - symmetric-db/src/main/java/org/jumpmind/db/sql/ISqlTransaction.java Diff File
mod - symmetric-io/src/main/java/org/jumpmind/symmetric/io/data/reader/ExtractDataReader.java Diff File
mod - symmetric-io/src/main/java/org/jumpmind/symmetric/io/data/reader/TableExtractDataReaderSource.java Diff File
mod - symmetric-io/src/main/java/org/jumpmind/symmetric/io/data/writer/DefaultDatabaseWriter.java Diff File
mod - symmetric-jdbc/src/main/java/org/jumpmind/db/platform/AbstractJdbcDdlReader.java Diff File
mod - symmetric-jdbc/src/main/java/org/jumpmind/db/platform/ase/AseJdbcSqlTransaction.java Diff File
mod - symmetric-jdbc/src/main/java/org/jumpmind/db/platform/informix/InformixJdbcSqlTemplate.java Diff File
mod - symmetric-jdbc/src/main/java/org/jumpmind/db/platform/mssql/MsSqlJdbcSqlTransaction.java Diff File
mod - symmetric-jdbc/src/main/java/org/jumpmind/db/sql/JdbcSqlTransaction.java Diff File
mod - symmetric-jdbc/src/test/resources/db-test.properties Diff File

SymmetricDS: master 0d7b5523

2014-12-12 15:44:27

chenson

Details Diff
0002090: Informix installations fail when existing SymmetricDS tables exist due to case sensitive comparisons
0002090
mod - symmetric-core/src/main/java/org/jumpmind/symmetric/db/AbstractTriggerTemplate.java Diff File

Issue History

Date Modified Username Field Change
2014-12-04 16:22 josh-a-hicks New Issue
2014-12-04 16:22 josh-a-hicks Status new => assigned
2014-12-04 16:22 josh-a-hicks Assigned To => josh-a-hicks
2014-12-04 17:00 josh-a-hicks Changeset attached => SymmetricDS trunk r9006
2014-12-04 17:00 josh-a-hicks Changeset attached => SymmetricDS 3.6 r9007
2014-12-10 10:11 chenson Product Version 3.7.0 => 3.6.15
2014-12-10 10:11 chenson Target Version 3.7.0 => 3.6.16
2014-12-10 10:11 chenson Project SymmetricDS Pro => SymmetricDS
2014-12-10 19:32 chenson Status assigned => resolved
2014-12-10 19:32 chenson Fixed in Version => 3.6.16
2014-12-10 19:32 chenson Resolution open => fixed
2014-12-11 07:46 chenson Status resolved => closed
2014-12-12 13:16 chenson Assigned To josh-a-hicks => chenson
2014-12-12 13:16 chenson Status closed => assigned
2014-12-12 13:16 chenson Fixed in Version 3.6.16 => 3.6.17
2014-12-12 13:16 chenson Target Version 3.6.16 => 3.6.17
2014-12-12 14:00 chenson Changeset attached => SymmetricDS 3.6 r9049
2014-12-12 14:00 chenson Changeset attached => SymmetricDS trunk r9050
2014-12-12 14:00 chenson Changeset attached => SymmetricDS 3.6 r9051
2014-12-12 16:00 chenson Changeset attached => SymmetricDS trunk r9060
2014-12-12 16:00 chenson Changeset attached => SymmetricDS 3.6 r9061
2014-12-13 18:55 chenson Status assigned => resolved
2014-12-26 08:37 chenson Status resolved => closed
2015-07-30 21:49 chenson Changeset attached => SymmetricDS master 0d7b5523
2015-07-30 21:49 chenson Changeset attached => SymmetricDS master 7f99a29c
2015-07-30 21:49 Changeset attached => SymmetricDS master 084353cf