View Issue Details

IDProjectCategoryView StatusLast Update
0002095SymmetricDSBugpublic2019-05-15 09:16
ReporterelongAssigned To 
Prioritynormal 
Status closedResolutionduplicate 
Product Version3.6.0 
Target VersionFixed in Version3.10.0 
Summary0002095: Create table (ddl utils) does not handle MySQL Enum
DescriptionUsing initial.load.create.first, SymmetricDS tries to create the column as:

... login ENUM(2) DEFAULT '0' NOT NULL,

When it should look like

... login ENUM('0', '1') NOT NULL DEFAULT '0'

Additional InformationNoticed that "describe table" works over JDBC and returns the correct ENUM definition.
Tagsddl/schema, dialect: mysql/mariadb

Relationships

duplicate of 0002849 closedpmarzullo Create Table maps a column originally created as an ENUM('y','n') to a Enum(2) 

Activities

pmarzullo

2019-05-14 14:10

developer   ~0001486

Looks to have been fixed by 2849

Issue History

Date Modified Username Field Change
2014-12-09 08:42 elong New Issue
2014-12-09 08:50 elong Additional Information Updated View Revisions
2019-04-23 12:38 elong Tag Attached: ddl/schema
2019-04-23 12:38 elong Tag Attached: mysql/mariadb
2019-04-23 16:49 admin Tag Renamed mysql/mariadb => dialect: mysql/mariadb
2019-05-14 14:09 pmarzullo Relationship added duplicate of 0002849
2019-05-14 14:10 pmarzullo Note Added: 0001486
2019-05-15 09:16 elong Status new => closed
2019-05-15 09:16 elong Resolution open => duplicate
2019-05-15 09:16 elong Fixed in Version => 3.10.0