View Issue Details

IDProjectCategoryView StatusLast Update
0002150SymmetricDS ProBugpublic2015-01-20 16:25
ReporterFeriyantoAssigned Tochenson 
PriorityhighSeveritymajorReproducibilityalways
Status closedResolutionfixed 
Product Version3.7.1 
Target Version3.7.2Fixed in Version3.7.2 
Summary0002150: Error when add Column in Configure column in expression
DescriptionWhen we want to create column match router configuration from web console,
we get error "An unexpected error accoured"

with this output log exception :

Caused by: com.vaadin.event.ListenerMethod$MethodException: Invocation of method buttonClick in com.jumpmind.symmetric.console.ui.form.RouterForm$ColumnRouterDialog$1 failed.
    at com.vaadin.event.ListenerMethod.receiveEvent(ListenerMethod.java:528)
    at com.vaadin.event.EventRouter.fireEvent(EventRouter.java:198)
    at com.vaadin.event.EventRouter.fireEvent(EventRouter.java:161)
    at com.vaadin.server.AbstractClientConnector.fireEvent(AbstractClientConnector.java:979)
    at com.vaadin.ui.Button.fireClick(Button.java:393)
    at com.vaadin.ui.Button$1.click(Button.java:57)
    ... 36 more
Caused by: java.lang.IllegalArgumentException: Value is of invalid type, got com.vaadin.ui.NativeSelect but com.vaadin.ui.ComboBox was expected
    at com.vaadin.data.util.IndexedContainer$IndexedContainerProperty.setValue(IndexedContainer.java:941)
    at com.vaadin.ui.Table.addItem(Table.java:2631)
    at com.jumpmind.symmetric.console.ui.form.RouterForm$ColumnRouterDialog$1.buttonClick(RouterForm.java:519)
    at sun.reflect.GeneratedMethodAccessor61.invoke(Unknown Source)
    at sun.reflect.DelegatingMethodAccessorImpl.invoke(Unknown Source)
    at java.lang.reflect.Method.invoke(Unknown Source)
    at com.vaadin.event.ListenerMethod.receiveEvent(ListenerMethod.java:508)
    ... 41 more
Steps To Reproduce1. Go to configure
2. Click Router
3. Add new router
4. on router type, choose column
5. Fokus the pointer to "Router Expression"

the pop up error will shown.
TagsNo tags attached.

Activities

Feriyanto

2015-01-20 15:47

reporter  

Capture.PNG (158,890 bytes)
Capture.PNG (158,890 bytes)

Feriyanto

2015-01-20 15:52

reporter   ~0000650

The error accour when click "+" button to add new row

Issue History

Date Modified Username Field Change
2015-01-20 15:47 Feriyanto New Issue
2015-01-20 15:47 Feriyanto File Added: Capture.PNG
2015-01-20 15:52 Feriyanto Note Added: 0000650
2015-01-20 16:25 chenson Fixed in Version => 3.7.2
2015-01-20 16:25 chenson Target Version => 3.7.2
2015-01-20 16:25 chenson Status new => closed
2015-01-20 16:25 chenson Assigned To => chenson
2015-01-20 16:25 chenson Resolution open => fixed