View Issue Details

IDProjectCategoryView StatusLast Update
0002155SymmetricDSImprovementpublic2015-01-28 09:03
ReporterelongAssigned Tochenson 
PrioritynormalSeverityminorReproducibilityhave not tried
Status closedResolutionfixed 
Product Version3.7.0 
Target Version3.7.3Fixed in Version3.7.3 
Summary0002155: Reduce updates to sym_node_communication
DescriptionWe've experienced problems on Firebird with blocking on the sym_node_communication table where it eventually needs to be dropped and recreated. It seems to happen because it is updated and locked so frequently. Let's check in-process if the node can communicate before using the table.
TagsNo tags attached.

Activities

There are no notes attached to this issue.

Related Changesets

SymmetricDS: master 69e5f1d1

2015-01-23 17:39:35

chenson

Details Diff
0002155: Reduce updates to sym_node_communication
0002155
mod - symmetric-core/src/main/java/org/jumpmind/symmetric/service/impl/NodeCommunicationService.java Diff File

Issue History

Date Modified Username Field Change
2015-01-23 12:30 elong New Issue
2015-01-23 12:30 elong Status new => assigned
2015-01-23 12:30 elong Assigned To => chenson
2015-01-23 17:43 chenson Status assigned => resolved
2015-01-23 17:43 chenson Fixed in Version => 3.7.3
2015-01-23 17:43 chenson Resolution open => fixed
2015-01-23 18:00 chenson Changeset attached => SymmetricDS trunk r9305
2015-01-28 09:03 chenson Status resolved => closed
2015-07-30 21:49 chenson Changeset attached => SymmetricDS master 69e5f1d1