View Issue Details

IDProjectCategoryView StatusLast Update
0002173SymmetricDSImprovementpublic2015-02-05 20:52
ReporterchensonAssigned Tochenson 
PrioritynormalSeverityminorReproducibilityhave not tried
Status closedResolutionfixed 
Product Version3.7.5 
Target Version3.7.5Fixed in Version3.7.5 
Summary0002173: "arithmetic exception, numeric overflow, or string truncation" on firebird due to row_data being > 10k. Log a better error msg.
Description"arithmetic exception, numeric overflow, or string truncation" on firebird due to row_data being > 10k. Log a better error msg.

We cast row_data and old_data to varchar(10000). If the row data exceeds 10k, then log an error that informs the user how to correct. To get rid of the cast set contains_big_lobs on the channel.
TagsNo tags attached.

Activities

There are no notes attached to this issue.

Related Changesets

SymmetricDS: master c1f1489f

2015-02-03 09:12:56

chenson

Details Diff
0002173: "arithmetic exception, numeric overflow, or string truncation" on firebird due to row_data being > 10k. Log a better error msg.
0002173
mod - symmetric-core/src/main/java/org/jumpmind/symmetric/route/DataGapRouteReader.java Diff File

SymmetricDS: master be4261cf

2015-02-03 09:17:11

chenson

Details Diff
0002173: "arithmetic exception, numeric overflow, or string truncation" on firebird due to row_data being > 10k. Log a better error msg.
0002173
mod - symmetric-core/src/main/java/org/jumpmind/symmetric/route/DataGapRouteReader.java Diff File

Issue History

Date Modified Username Field Change
2015-02-03 09:12 chenson New Issue
2015-02-03 09:12 chenson Status new => assigned
2015-02-03 09:12 chenson Assigned To => chenson
2015-02-03 09:13 chenson Status assigned => resolved
2015-02-03 09:13 chenson Fixed in Version => 3.7.5
2015-02-03 09:13 chenson Resolution open => fixed
2015-02-03 10:00 chenson Changeset attached => SymmetricDS trunk r9342
2015-02-03 10:00 chenson Changeset attached => SymmetricDS trunk r9343
2015-02-05 20:52 chenson Status resolved => closed
2015-07-30 21:49 chenson Changeset attached => SymmetricDS master be4261cf
2015-07-30 21:49 chenson Changeset attached => SymmetricDS master c1f1489f