View Issue Details

IDProjectCategoryView StatusLast Update
0002190SymmetricDSBugpublic2019-04-23 15:01
ReporterazarubkinAssigned Toelong 
Prioritynormal 
Status closedResolutionfixed 
Product Version3.6.4 
Target VersionFixed in Version3.9.5 
Summary0002190: PID file is not cleaned up on startup
DescriptionPID file is not cleaned up on startup. This has led to a problem I'm describing below.

A power shortage has happened, leaving the PID file behind. After reboot, another process has taken that PID, and SymmetricDS service does not start anymore, because it thinks it's already started!

The solution to it is described here: http://stackoverflow.com/questions/2134732/pid-files-hanging-around-for-daemons-after-server-restart
Steps To ReproduceThe bug is random, depending on PID assignment by OS.
TagsNo tags attached.

Relationships

related to 0003430 closedelong Service wrapper should verify and kill abandoned processes 

Activities

azarubkin

2015-02-12 07:26

reporter   ~0000668

I suspect that you can reproduce the bug by manually creating the pid file which contains the pid of another process.

elong

2019-04-23 15:01

developer   ~0001421

Should be fixed in 0003430.

Issue History

Date Modified Username Field Change
2015-02-12 07:22 azarubkin New Issue
2015-02-12 07:26 azarubkin Note Added: 0000668
2019-04-23 15:00 elong Relationship added related to 0003430
2019-04-23 15:01 elong Assigned To => elong
2019-04-23 15:01 elong Status new => closed
2019-04-23 15:01 elong Resolution open => fixed
2019-04-23 15:01 elong Fixed in Version => 3.9.5
2019-04-23 15:01 elong Note Added: 0001421