View Issue Details

IDProjectCategoryView StatusLast Update
0002222SymmetricDSBugpublic2015-03-06 10:16
ReporterelongAssigned Toelong 
PrioritynormalSeverityminorReproducibilityalways
Status closedResolutionfixed 
Product Version3.7.0 
Target Version3.7.9Fixed in Version3.7.9 
Summary0002222: BSH transform context variables overwrite column variables
DescriptionFor BeanShell (BSH) column transforms, the key/value pairs from the context are bound to variables in the script, which can overwrite the column values. This behavior should be removed since it is not documented and it causes problems that are hard to find.
TagsNo tags attached.

Activities

There are no notes attached to this issue.

Related Changesets

SymmetricDS: master 886a4c32

2015-03-02 14:58:33

erilong

Details Diff
0002222: BSH transform context variables overwrite column variables
0002222
mod - symmetric-core/src/main/java/org/jumpmind/symmetric/io/data/transform/BshColumnTransform.java Diff File

Issue History

Date Modified Username Field Change
2015-03-02 14:50 elong New Issue
2015-03-02 14:50 elong Status new => assigned
2015-03-02 14:50 elong Assigned To => elong
2015-03-02 15:00 Changeset attached => SymmetricDS trunk r9387
2015-03-02 15:17 elong Status assigned => resolved
2015-03-02 15:17 elong Fixed in Version => 3.7.9
2015-03-02 15:17 elong Resolution open => fixed
2015-03-06 10:16 chenson Status resolved => closed
2015-07-30 21:49 Changeset attached => SymmetricDS master 886a4c32