View Issue Details

IDProjectCategoryView StatusLast Update
0002333SymmetricDSBugpublic2015-08-13 11:00
ReporterabrougherAssigned Tochenson 
PrioritynormalSeverityminorReproducibilityalways
Status closedResolutionfixed 
Product Version3.7.9 
Target Version3.7.20Fixed in Version3.7.20 
Summary0002333: Audit router inserts failing due to case sensitive collation
DescriptionAudit router and table were created correctly using SDS Pro. Data change and routing worked correctly. The audit table insert failed due to the column name case.

The following exception was generated in the log file...



2015-06-26 08:04:34,486 ERROR [corp] [RouterService] [corp-job-19] Failed to route and batch data on 'default' channel
org.jumpmind.db.sql.SqlException: Invalid column name 'AUDIT_ID'.
    at org.jumpmind.db.sql.AbstractSqlTemplate.translate(AbstractSqlTemplate.java:288)
    at org.jumpmind.db.sql.AbstractSqlTemplate.translate(AbstractSqlTemplate.java:279)
    at org.jumpmind.db.sql.JdbcSqlTemplate.execute(JdbcSqlTemplate.java:434)
    at org.jumpmind.db.sql.JdbcSqlTemplate.queryForObject(JdbcSqlTemplate.java:140)
    at org.jumpmind.db.sql.AbstractSqlTemplate.queryForLong(AbstractSqlTemplate.java:80)
    at org.jumpmind.symmetric.route.AuditTableDataRouter.routeToNodes(AuditTableDataRouter.java:99)
    at org.jumpmind.symmetric.service.impl.RouterService.routeData(RouterService.java:692)
    at org.jumpmind.symmetric.service.impl.RouterService.selectDataAndRoute(RouterService.java:613)
    at org.jumpmind.symmetric.service.impl.RouterService.routeDataForChannel(RouterService.java:415)
    at org.jumpmind.symmetric.service.impl.RouterService.routeDataForEachChannel(RouterService.java:331)
    at org.jumpmind.symmetric.service.impl.RouterService.routeData(RouterService.java:175)
    at org.jumpmind.symmetric.job.RouterJob.doJob(RouterJob.java:40)
    at org.jumpmind.symmetric.job.AbstractJob.invoke(AbstractJob.java:180)
    at org.jumpmind.symmetric.job.AbstractJob.run(AbstractJob.java:224)
    at org.springframework.scheduling.support.DelegatingErrorHandlingRunnable.run(DelegatingErrorHandlingRunnable.java:54)
    at java.util.concurrent.Executors$RunnableAdapter.call(Executors.java:471)
    at java.util.concurrent.FutureTask.runAndReset(FutureTask.java:304)
    at java.util.concurrent.ScheduledThreadPoolExecutor$ScheduledFutureTask.access$301(ScheduledThreadPoolExecutor.java:178)
    at java.util.concurrent.ScheduledThreadPoolExecutor$ScheduledFutureTask.run(ScheduledThreadPoolExecutor.java:293)
    at java.util.concurrent.ThreadPoolExecutor.runWorker(ThreadPoolExecutor.java:1145)
    at java.util.concurrent.ThreadPoolExecutor$Worker.run(ThreadPoolExecutor.java:615)
    at java.lang.Thread.run(Thread.java:745)
Caused by: java.sql.SQLException: Invalid column name 'AUDIT_ID'.
    at net.sourceforge.jtds.jdbc.SQLDiagnostic.addDiagnostic(SQLDiagnostic.java:372)
    at net.sourceforge.jtds.jdbc.TdsCore.tdsErrorToken(TdsCore.java:2894)
    at net.sourceforge.jtds.jdbc.TdsCore.nextToken(TdsCore.java:2334)
    at net.sourceforge.jtds.jdbc.TdsCore.getMoreResults(TdsCore.java:643)
    at net.sourceforge.jtds.jdbc.MSCursorResultSet.processOutput(MSCursorResultSet.java:943)
    at net.sourceforge.jtds.jdbc.MSCursorResultSet.cursorCreate(MSCursorResultSet.java:541)
    at net.sourceforge.jtds.jdbc.MSCursorResultSet.<init>(MSCursorResultSet.java:154)
    at net.sourceforge.jtds.jdbc.JtdsStatement.executeSQLQuery(JtdsStatement.java:453)
    at net.sourceforge.jtds.jdbc.JtdsPreparedStatement.executeQuery(JtdsPreparedStatement.java:979)
    at org.apache.commons.dbcp.DelegatingPreparedStatement.executeQuery(DelegatingPreparedStatement.java:96)
    at org.apache.commons.dbcp.DelegatingPreparedStatement.executeQuery(DelegatingPreparedStatement.java:96)
    at org.jumpmind.db.sql.JdbcSqlTemplate$1.execute(JdbcSqlTemplate.java:149)
    at org.jumpmind.db.sql.JdbcSqlTemplate.execute(JdbcSqlTemplate.java:432)
    ... 19 more
TagsNo tags attached.

Activities

There are no notes attached to this issue.

Related Changesets

SymmetricDS: master 091627e4

2015-06-26 09:37:59

chenson

Details Diff
0002333: Audit router inserts failing due to case sensitive collation
0002333
mod - symmetric-core/src/main/java/org/jumpmind/symmetric/route/AuditTableDataRouter.java Diff File

SymmetricDS: 3.7 bd07a8cd

2015-06-26 09:47:41

chenson

Details Diff
0002333: Audit router inserts failing due to case sensitive collation
0002333
mod - symmetric-core/src/main/java/org/jumpmind/symmetric/route/AuditTableDataRouter.java Diff File

SymmetricDS: master 847fd6bd

2015-06-26 10:42:10

chenson

Details Diff
0002333: Audit router inserts failing due to case sensitive collation
0002333
mod - symmetric-core/src/main/java/org/jumpmind/symmetric/route/AuditTableDataRouter.java Diff File

SymmetricDS: 3.7 1fed3c0a

2015-06-26 10:44:34

chenson

Details Diff
0002333: Audit router inserts failing due to case sensitive collation
0002333
mod - symmetric-core/src/main/java/org/jumpmind/symmetric/route/AuditTableDataRouter.java Diff File

Issue History

Date Modified Username Field Change
2015-06-26 08:07 abrougher New Issue
2015-06-26 08:07 abrougher Status new => assigned
2015-06-26 08:07 abrougher Assigned To => abrougher
2015-06-26 09:23 chenson Assigned To abrougher => chenson
2015-06-26 09:23 chenson Fixed in Version => 3.7.20
2015-06-26 09:23 chenson Target Version 3.8.0 => 3.7.20
2015-06-26 09:48 chenson Status assigned => resolved
2015-06-26 09:48 chenson Resolution open => fixed
2015-06-26 10:00 chenson Changeset attached => SymmetricDS trunk r9531
2015-06-26 10:00 chenson Changeset attached => SymmetricDS 3.7 r9532
2015-06-26 11:00 chenson Changeset attached => SymmetricDS trunk r9537
2015-06-26 11:00 chenson Changeset attached => SymmetricDS 3.7 r9538
2015-07-30 21:49 chenson Changeset attached => SymmetricDS master 847fd6bd
2015-07-30 21:49 chenson Changeset attached => SymmetricDS master 091627e4
2015-08-08 14:10 chenson Status resolved => closed
2015-08-13 11:00 chenson Changeset attached => SymmetricDS 3.7 1fed3c0a
2015-08-13 11:00 chenson Changeset attached => SymmetricDS 3.7 bd07a8cd