View Issue Details

IDProjectCategoryView StatusLast Update
0002369SymmetricDSBugpublic2019-08-26 08:45
ReportersteffenbAssigned To 
Prioritynormal 
Status closedResolutionopen 
Product Version3.7.19 
Target VersionFixed in Version 
Summary0002369: Firebird exception: "Implementation limit exceeded" when installing Sym tables
DescriptionI was following the install guide on SymmetricDS to try it out.
Both on an existing database and on a newly created one, it fails when creating the SymmetricDS tables in step 2.1.1.
Steps To Reproduce1. Create an empty Firebird DB.
2. Changed *.properties files to use firebird driver and our user/password.
3. ../bin/dbimport --engine corp-000 --format XML --alter-case create_sample.xml
4. ../bin/symadmin --engine corp-000 create-sym-tables
It install many tables but eventually fails:

declare external function sym_hex blob
  returns cstring(32660) free_it entry_point 'sym_hex' module_name 'sym_udf'
-------------------------------------------------------------------------------
An exception occurred. Please see the following for details:
-------------------------------------------------------------------------------
org.firebirdsql.jdbc.FBSQLException: GDS Exception. 335544569. Dynamic SQL Error
SQL error code = -204
Data type unknown
Implementation limit exceeded
COLUMN DSQL internal
    at org.firebirdsql.jdbc.AbstractPreparedStatement.<init>(AbstractPreparedStatement.java:147)
    at org.firebirdsql.jdbc.FBPreparedStatement.<init>(FBPreparedStatement.java:46)
    at sun.reflect.GeneratedConstructorAccessor6.newInstance(Unknown Source)
Additional InformationAttached log file.
I tried a few times, last time on a DB already containing some tables from previous attempt.
TagsNo tags attached.

Activities

steffenb

2015-08-11 08:53

reporter  

symmetric.log (85,191 bytes)

elong

2019-04-23 15:25

developer   ~0001424

Did you follow the Firebird notes to copy the sym_udf file to the server?

https://www.symmetricds.org/doc/3.10/html/user-guide.html#_firebird

The logs you attached look clean. I don't see that error in the logs. We test on Firebird 2.5, and can't reproduce this.

admin

2019-08-26 08:45

administrator   ~0001589

Auto closing all issues waiting for feedback after 4 months. We don't have enough information to take any action.

Issue History

Date Modified Username Field Change
2015-08-11 08:53 steffenb New Issue
2015-08-11 08:53 steffenb File Added: symmetric.log
2019-04-23 15:25 elong Assigned To => elong
2019-04-23 15:25 elong Status new => feedback
2019-04-23 15:25 elong Note Added: 0001424
2019-04-23 15:25 elong Assigned To elong =>
2019-08-26 08:45 admin Note Added: 0001589
2019-08-26 08:45 admin Status feedback => closed