View Issue Details

IDProjectCategoryView StatusLast Update
0002436SymmetricDSBugpublic2016-05-11 08:27
ReportertbergerAssigned Tochenson 
PrioritynormalSeverityminorReproducibilityalways
Status closedResolutionfixed 
Product Version3.7.22 
Target Version3.7.28Fixed in Version3.7.28 
Summary0002436: INSERT converted to UPDATE without FALLBACK conflict resolution
DescriptionSynchronizing a table between MS SQL and MySQL, an INSERT into the MS SQL table is converted to an UPDATE on the MySQL side, resulting in a conflict (if detect_type is set to USE_OLD_DATA and resolve_type to IGNORE or MANUAL) because the row does not exist yet.
Additional InformationThe problem does not occur with SymmetricDS version 3.7.21.
TagsNo tags attached.

Activities

tberger

2016-05-11 08:06

reporter   ~0000789

Works again here since at least version 3.7.30.

elong

2016-05-11 08:27

developer   ~0000790

Issue 0002367 in 3.7.22 caused this problem, and then it was fixed by issue 0002467 in 3.7.28.

Issue History

Date Modified Username Field Change
2015-11-04 13:14 tberger New Issue
2016-05-11 08:06 tberger Note Added: 0000789
2016-05-11 08:27 elong Note Added: 0000790
2016-05-11 08:27 elong Assigned To => chenson
2016-05-11 08:27 elong Status new => closed
2016-05-11 08:27 elong Resolution open => fixed
2016-05-11 08:27 elong Product Version 3.7.26 => 3.7.22
2016-05-11 08:27 elong Fixed in Version => 3.7.28
2016-05-11 08:27 elong Target Version => 3.7.28