View Issue Details

IDProjectCategoryView StatusLast Update
0002442SymmetricDS ProBugpublic2015-11-17 16:02
ReportermhanesAssigned Tomhanes 
PrioritynormalSeveritymajorReproducibilityalways
Status closedResolutionfixed 
Product Version3.7.26 
Target Version3.7.27Fixed in Version3.7.27 
Summary0002442: JMX enable and port setttings not being written to symmetric-server.properties on install
DescriptionThe user-specified JMX settings in the install wizard (enabled and port value) don't seem to be written to symmetric-server.properties anymore. Thus, it appears that when SymmetricDS starts up, the defaults are used, resulting in JMX being enabled and using port 31416. This is a problem for a few reasons, one of which is if you happen to install two instances of SymmetricDS on the same machine, the second one won't start due to using the same port the first one is using (a port which might not even be what the user had specified).
Steps To ReproduceInstall symmetric using a different port than the default for JMX. Start up SymmetricDS, and you'll see in the log the port was not honored.
TagsNo tags attached.

Activities

There are no notes attached to this issue.

Issue History

Date Modified Username Field Change
2015-11-10 07:11 mhanes New Issue
2015-11-10 07:20 mhanes Assigned To => mhanes
2015-11-10 07:20 mhanes Status new => assigned
2015-11-10 07:49 chenson Status assigned => resolved
2015-11-10 07:49 chenson Fixed in Version => 3.7.27
2015-11-10 07:49 chenson Resolution open => fixed
2015-11-17 16:02 chenson Status resolved => closed