View Issue Details

IDProjectCategoryView StatusLast Update
0002459SymmetricDSBugpublic2016-04-28 10:01
ReportermmichalekAssigned Tommichalek 
PrioritynormalSeverityminorReproducibilitysometimes
Status closedResolutionfixed 
Product Version3.7.27 
Target Version3.7.27Fixed in Version3.7.28 
Summary0002459: Timestamp Values may get exported with invalid format
DescriptionDiscovered in testing, a timestamp value got exported with no fractional second. The timestamp portion of the value "2015-12-02 06:49:13. -08:00" is invalid, as it ends with a decimal point.

2015-12-02 10:10:48,914 INFO [client-003-oracle2ndNode] [DefaultDatabaseWriter] [client-003-oracle2ndnode-pull-1] Failed to process a insert event in batch 64.
Failed sql was: insert into "SYMMETRIC2NDNODE"."SDS_TEST_D095" ("SEQNO", "TS0", "TS3", "TS6", "TS9") values (?,TO_TIMESTAMP_TZ(?, 'YYYY-MM-DD HH24:MI:SS.FF TZH:TZM'),TO_TIMESTAMP_TZ(?, 'YYYY-MM-DD HH24:MI:SS.FF TZH:TZM'),TO_TIMESTAMP_TZ(?, 'YYYY-MM-DD HH24:MI:SS.FF TZH:TZM'),TO_TIMESTAMP_TZ(?, 'YYYY-MM-DD HH24:MI:SS.FF TZH:TZM'))
Failed sql parameters: [1, 2015-12-02 06:49:13. -08:00, 2015-12-02 06:49:12.532 -08:00, 2015-12-02 06:49:12.532487 -08:00, 2015-12-02 06:49:12.532487000 -08:00]
Failed sql parameters types: [3, -101, -101, -101, -101]
Failed row data was: "1","2015-12-02 06:49:13. -08:00","2015-12-02 06:49:12.532 -08:00","2015-12-02 06:49:12.532487 -08:00","2015-12-02 06:49:12.532487000 -08:00"

2015-12-02 10:10:48,931 ERROR [client-003-oracle2ndNode] [DataLoaderService] [client-003-oracle2ndnode-pull-1] Failed to load batch server-64 because: ORA-01880: the fractional seconds must be between 0 and 999999999

org.jumpmind.db.sql.SqlException: ORA-01880: the fractional seconds must be between 0 and 999999999

    at org.jumpmind.db.sql.AbstractSqlTemplate.translate(AbstractSqlTemplate.java:288)
    at org.jumpmind.db.sql.AbstractSqlTemplate.translate(AbstractSqlTemplate.java:279)
    at org.jumpmind.db.sql.JdbcSqlTransaction.addRow(JdbcSqlTransaction.java:410)
    at org.jumpmind.symmetric.io.data.writer.DefaultDatabaseWriter.execute(DefaultDatabaseWriter.java:786)
    at org.jumpmind.symmetric.io.data.writer.DefaultDatabaseWriter.insert(DefaultDatabaseWriter.java:174)
    at org.jumpmind.symmetric.io.data.writer.AbstractDatabaseWriter.write(AbstractDatabaseWriter.java:155)
    at org.jumpmind.symmetric.io.data.writer.NestedDataWriter.write(NestedDataWriter.java:64)
    at org.jumpmind.symmetric.model.ProcessInfoDataWriter.write(ProcessInfoDataWriter.java:65)
    at org.jumpmind.symmetric.io.data.writer.NestedDataWriter.write(NestedDataWriter.java:64)
    at org.jumpmind.symmetric.io.data.writer.TransformWriter.write(TransformWriter.java:204)
    at org.jumpmind.symmetric.io.data.DataProcessor.forEachDataInTable(DataProcessor.java:200)
    at org.jumpmind.symmetric.io.data.DataProcessor.forEachTableInBatch(DataProcessor.java:170)
    at org.jumpmind.symmetric.io.data.DataProcessor.process(DataProcessor.java:116)
    at org.jumpmind.symmetric.service.impl.DataLoaderService$LoadIntoDatabaseOnArrivalListener.end(DataLoaderService.java:850)
    at org.jumpmind.symmetric.io.data.writer.StagingDataWriter.notifyEndBatch(StagingDataWriter.java:75)
    at org.jumpmind.symmetric.io.data.writer.AbstractProtocolDataWriter.end(AbstractProtocolDataWriter.java:220)
    at org.jumpmind.symmetric.io.data.DataProcessor.process(DataProcessor.java:130)
    at org.jumpmind.symmetric.service.impl.DataLoaderService.loadDataFromTransport(DataLoaderService.java:458)
    at org.jumpmind.symmetric.service.impl.DataLoaderService.loadDataFromPull(DataLoaderService.java:268)
    at org.jumpmind.symmetric.service.impl.PullService.execute(PullService.java:132)
    at org.jumpmind.symmetric.service.impl.NodeCommunicationService$2.run(NodeCommunicationService.java:396)
    at java.util.concurrent.ThreadPoolExecutor.runWorker(ThreadPoolExecutor.java:1145)
    at java.util.concurrent.ThreadPoolExecutor$Worker.run(ThreadPoolExecutor.java:615)
    at java.lang.Thread.run(Thread.java:745)
Caused by: java.sql.SQLException: ORA-01880: the fractional seconds must be between 0 and 999999999

    at oracle.jdbc.driver.T4CTTIoer.processError(T4CTTIoer.java:445)
    at oracle.jdbc.driver.T4CTTIoer.processError(T4CTTIoer.java:396)
    at oracle.jdbc.driver.T4C8Oall.processError(T4C8Oall.java:879)
    at oracle.jdbc.driver.T4CTTIfun.receive(T4CTTIfun.java:450)
    at oracle.jdbc.driver.T4CTTIfun.doRPC(T4CTTIfun.java:192)
    at oracle.jdbc.driver.T4C8Oall.doOALL(T4C8Oall.java:531)
    at oracle.jdbc.driver.T4CPreparedStatement.doOall8(T4CPreparedStatement.java:207)
    at oracle.jdbc.driver.T4CPreparedStatement.executeForRows(T4CPreparedStatement.java:1037)
    at oracle.jdbc.driver.OracleStatement.doExecuteWithTimeout(OracleStatement.java:1329)
    at oracle.jdbc.driver.OraclePreparedStatement.executeInternal(OraclePreparedStatement.java:3584)
    at oracle.jdbc.driver.OraclePreparedStatement.execute(OraclePreparedStatement.java:3685)
    at oracle.jdbc.driver.OraclePreparedStatementWrapper.execute(OraclePreparedStatementWrapper.java:1088)
    at org.apache.commons.dbcp.DelegatingPreparedStatement.execute(DelegatingPreparedStatement.java:172)
    at org.apache.commons.dbcp.DelegatingPreparedStatement.execute(DelegatingPreparedStatement.java:172)
    at org.jumpmind.db.sql.JdbcSqlTransaction.addRow(JdbcSqlTransaction.java:406)
    ... 21 more
TagsNo tags attached.

Activities

There are no notes attached to this issue.

Related Changesets

SymmetricDS: 3.7 7919469e

2015-12-02 11:10:17

mmichalek

Details Diff
0002459: Timestamp Values may get exported with invalid format
0002459
mod - symmetric-client/src/main/java/org/jumpmind/symmetric/db/oracle/OracleTriggerTemplate.java Diff File

SymmetricDS: 3.8 c404d469

2015-12-02 11:10:17

mmichalek

Details Diff
0002459: Timestamp Values may get exported with invalid format
0002459
mod - symmetric-client/src/main/java/org/jumpmind/symmetric/db/oracle/OracleTriggerTemplate.java Diff File

Issue History

Date Modified Username Field Change
2015-12-02 10:15 mmichalek New Issue
2015-12-02 10:15 mmichalek Assigned To => mmichalek
2015-12-02 10:15 mmichalek Status new => assigned
2015-12-02 10:34 mmichalek Description Updated View Revisions
2015-12-02 11:16 mmichalek Status assigned => resolved
2015-12-02 11:16 mmichalek Resolution open => fixed
2015-12-02 11:16 mmichalek Product Version => 3.7.27
2015-12-02 11:16 mmichalek Fixed in Version => 3.7.28
2015-12-02 11:16 mmichalek Target Version => 3.7.27
2015-12-02 12:00 mmichalek Changeset attached => SymmetricDS 3.7 7919469e
2016-01-03 16:44 chenson Status resolved => closed
2016-04-28 10:01 mmichalek Changeset attached => SymmetricDS 3.8 c404d469