View Issue Details

IDProjectCategoryView StatusLast Update
0002483SymmetricDSBugpublic2016-02-12 13:26
ReporterelongAssigned Toelong 
PrioritynormalSeverityminorReproducibilitysometimes
Status closedResolutionfixed 
Product Version3.7.0 
Target Version3.7.29Fixed in Version3.7.29 
Summary0002483: Xml Publisher: data not legal for JDOM
DescriptionThe XML Publisher can throw an exception and prevent batches from loading when invalid characters are present in the batch. The underlying JDOM library used to generate XML is strict about which characters can be used.

[DataLoaderService]
[web-pull-1] Failed to load batch server-6537303 because: The data
"123 " is not legal for a JDOM character content: 0x1f is
not a legal XML character.

org.jdom.IllegalDataException: The data "123 " is not
legal for a JDOM character content: 0x1f is not a legal XML character.
TagsNo tags attached.

Activities

There are no notes attached to this issue.

Related Changesets

SymmetricDS: 3.7 ca609d90

2016-01-20 14:56:29

admin

Details Diff
0002483: Xml Publisher: data not legal for JDOM
0002483
mod - symmetric-server/src/main/java/org/jumpmind/symmetric/integrate/AbstractXmlPublisherExtensionPoint.java Diff File

Issue History

Date Modified Username Field Change
2016-01-20 14:22 elong New Issue
2016-01-20 14:22 elong Status new => assigned
2016-01-20 14:22 elong Assigned To => elong
2016-01-20 14:56 elong Status assigned => resolved
2016-01-20 14:56 elong Fixed in Version => 3.7.29
2016-01-20 14:56 elong Resolution open => fixed
2016-01-20 15:00 admin Changeset attached => SymmetricDS 3.7 ca609d90
2016-02-12 13:26 chenson Status resolved => closed