View Issue Details

IDProjectCategoryView StatusLast Update
0002490SymmetricDSBugpublic2016-02-24 11:00
Reporterjosh-a-hicksAssigned Tojosh-a-hicks 
PrioritynormalSeverityminorReproducibilityalways
Status closedResolutionfixed 
Product Version3.7.0 
Target Version3.7.29Fixed in Version3.7.30 
Summary0002490: Oracle ddl reader not escaping "_"
DescriptionThe "_" is being used as a wildcard for any other character. This is fine if there is not another table with a value matching the wildcard.

Example:
TR_TRN
TRXTRN

This would create additional triggers on TRXTRN since it treats the "_" as a wildcard and doesnt find 2 different tables.

TagsNo tags attached.

Activities

There are no notes attached to this issue.

Related Changesets

SymmetricDS: 3.7 a2bb2f3e

2016-02-05 16:34:46

Hicks, Josh

Details Diff
0002490 - Oracle support for tables with "_" so that it is not treated
as a wildcard.

0002490
mod - symmetric-jdbc/src/main/java/org/jumpmind/db/platform/oracle/OracleDdlReader.java Diff File

Issue History

Date Modified Username Field Change
2016-02-05 16:33 josh-a-hicks New Issue
2016-02-05 16:33 josh-a-hicks Status new => assigned
2016-02-05 16:33 josh-a-hicks Assigned To => josh-a-hicks
2016-02-24 10:39 josh-a-hicks Status assigned => closed
2016-02-24 10:39 josh-a-hicks Resolution open => fixed
2016-02-24 10:39 josh-a-hicks Fixed in Version => 3.7.30
2016-02-24 11:00 Changeset attached => SymmetricDS 3.7 a2bb2f3e