View Issue Details

IDProjectCategoryView StatusLast Update
0002520SymmetricDS ProBugpublic2016-03-14 20:03
ReporterelongAssigned Toelong 
PrioritynormalSeverityminorReproducibilityalways
Status closedResolutionfixed 
Product Version3.7.0 
Target Version3.7.30Fixed in Version3.7.30 
Summary0002520: Multi-master with multiple groups not showing hierarchy on nodes panel
DescriptionThe Manage->Nodes panel shows all the nodes and their hierarchy of who registered with who. If the configuration is multi-master where a group is configured to push to the same group, the create_at_node_id is not recorded on sym_node. If there is a registration node (or other groups involved), the hierarchy is not displayed because created_at_node_id is null.
Steps To ReproduceSetup root and master node groups. Link master to master. Link master to root. Register master nodes with root server. No hierarchy is displayed.
TagsNo tags attached.

Activities

There are no notes attached to this issue.

Related Changesets

SymmetricDS: 3.7 d58608a6

2016-03-08 16:32:22

admin

Details Diff
0002520: Multi-master with multiple groups not showing hierarchy on
nodes panel

0002520
mod - symmetric-core/src/main/java/org/jumpmind/symmetric/service/IConfigurationService.java Diff File
mod - symmetric-core/src/main/java/org/jumpmind/symmetric/service/impl/ConfigurationService.java Diff File
mod - symmetric-core/src/main/java/org/jumpmind/symmetric/service/impl/ConfigurationServiceSqlMap.java Diff File
mod - symmetric-core/src/main/java/org/jumpmind/symmetric/service/impl/RegistrationService.java Diff File

Issue History

Date Modified Username Field Change
2016-03-08 16:09 elong New Issue
2016-03-08 16:09 elong Status new => assigned
2016-03-08 16:09 elong Assigned To => elong
2016-03-08 17:00 admin Changeset attached => SymmetricDS 3.7 d58608a6
2016-03-14 20:03 elong Status assigned => resolved
2016-03-14 20:03 elong Fixed in Version => 3.7.30
2016-03-14 20:03 elong Resolution open => fixed
2016-03-14 20:03 elong Status resolved => closed