View Issue Details

IDProjectCategoryView StatusLast Update
0002538SymmetricDS ProBugpublic2016-04-28 10:01
ReporterchensonAssigned Tochenson 
PrioritynormalSeverityminorReproducibilityhave not tried
Status closedResolutionfixed 
Product Version3.7.30 
Target Version3.7.31Fixed in Version3.7.31 
Summary0002538: Error on Incoming Batch Panel
Descriptioncom.vaadin.server.ServerRpcManager$RpcInvocationException: Unable to invoke method click in com.vaadin.shared.ui.button.ButtonServerRpc
          at com.vaadin.server.ServerRpcManager.applyInvocation(ServerRpcManager.java:170)
          at com.vaadin.server.ServerRpcManager.applyInvocation(ServerRpcManager.java:118)
          at com.vaadin.server.communication.ServerRpcHandler.handleInvocations(ServerRpcHandler.java:287)
          at com.vaadin.server.communication.ServerRpcHandler.handleRpc(ServerRpcHandler.java:180)
          at com.vaadin.server.communication.UidlRequestHandler.synchronizedHandleRequest(UidlRequestHandler.java:93)
          at com.vaadin.server.SynchronizedRequestHandler.handleRequest(SynchronizedRequestHandler.java:41)
          at com.vaadin.server.VaadinService.handleRequest(VaadinService.java:1406)
          at com.vaadin.server.VaadinServlet.service(VaadinServlet.java:305)
          at com.jumpmind.symmetric.console.ui.AppServlet.service(AppServlet.java:36)
          at javax.servlet.http.HttpServlet.service(HttpServlet.java:790)
          at org.eclipse.jetty.servlet.ServletHolder.handle(ServletHolder.java:808)
          at org.eclipse.jetty.servlet.ServletHandler.doHandle(ServletHandler.java:587)
          at org.eclipse.jetty.server.handler.ScopedHandler.handle(ScopedHandler.java:143)
          at org.eclipse.jetty.security.SecurityHandler.handle(SecurityHandler.java:577)
          at org.eclipse.jetty.server.session.SessionHandler.doHandle(SessionHandler.java:223)
          at org.eclipse.jetty.server.handler.ContextHandler.doHandle(ContextHandler.java:1127)
          at org.eclipse.jetty.servlet.ServletHandler.doScope(ServletHandler.java:515)
          at org.eclipse.jetty.server.session.SessionHandler.doScope(SessionHandler.java:185)
          at org.eclipse.jetty.server.handler.ContextHandler.doScope(ContextHandler.java:1061)
          at org.eclipse.jetty.server.handler.ScopedHandler.handle(ScopedHandler.java:141)
          at org.eclipse.jetty.server.handler.HandlerWrapper.handle(HandlerWrapper.java:97)
          at org.eclipse.jetty.server.Server.handle(Server.java:499)
          at org.eclipse.jetty.server.HttpChannel.handle(HttpChannel.java:310)
          at org.eclipse.jetty.server.HttpConnection.onFillable(HttpConnection.java:257)
          at org.eclipse.jetty.io.AbstractConnection$2.run(AbstractConnection.java:540)
          at org.eclipse.jetty.util.thread.QueuedThreadPool.runJob(QueuedThreadPool.java:635)
          at org.eclipse.jetty.util.thread.QueuedThreadPool$3.run(QueuedThreadPool.java:555)
          at java.lang.Thread.run(Thread.java:745)
Caused by: java.lang.reflect.InvocationTargetException
          at sun.reflect.GeneratedMethodAccessor71.invoke(Unknown Source)
          at sun.reflect.DelegatingMethodAccessorImpl.invoke(DelegatingMethodAccessorImpl.java:43)
          at java.lang.reflect.Method.invoke(Method.java:497)
          at com.vaadin.server.ServerRpcManager.applyInvocation(ServerRpcManager.java:168)
          ... 27 more
Caused by: com.vaadin.event.ListenerMethod$MethodException: Invocation of method buttonClick in com.jumpmind.symmetric.console.ui.screen.f failed.
          at com.vaadin.event.ListenerMethod.receiveEvent(ListenerMethod.java:528)
          at com.vaadin.event.EventRouter.fireEvent(EventRouter.java:198)
          at com.vaadin.event.EventRouter.fireEvent(EventRouter.java:161)
          at com.vaadin.server.AbstractClientConnector.fireEvent(AbstractClientConnector.java:979)
          at com.vaadin.ui.Button.fireClick(Button.java:393)
          at com.vaadin.ui.Button$1.click(Button.java:57)
          ... 31 more
Caused by: java.lang.RuntimeException: Error in bean construction or property population with default values.
          at org.vaadin.addons.lazyquerycontainer.AbstractBeanQuery.constructItem(AbstractBeanQuery.java:125)
          at org.vaadin.addons.lazyquerycontainer.LazyQueryView.queryItem(LazyQueryView.java:294)
          at org.vaadin.addons.lazyquerycontainer.LazyQueryView.getItem(LazyQueryView.java:262)
          at org.vaadin.addons.lazyquerycontainer.LazyIdList.get(LazyIdList.java:92)
          at org.vaadin.addons.lazyquerycontainer.LazyQueryContainer.getIdByIndex(LazyQueryContainer.java:228)
          at com.vaadin.data.ContainerHelpers.getItemIdsUsingGetIdByIndex(ContainerHelpers.java:88)
          at org.vaadin.addons.lazyquerycontainer.LazyQueryContainer.getItemIds(LazyQueryContainer.java:647)
          at com.vaadin.ui.Table.getItemIds(Table.java:2241)
          at com.vaadin.ui.Table.getVisibleCellsNoCache(Table.java:2191)
          at com.vaadin.ui.Table.refreshRenderedCells(Table.java:1717)
          at com.vaadin.ui.Table.attach(Table.java:4249)
          at com.vaadin.server.AbstractClientConnector.attach(AbstractClientConnector.java:592)
          at com.vaadin.ui.AbstractComponent.attach(AbstractComponent.java:577)
          at com.vaadin.server.AbstractClientConnector.attach(AbstractClientConnector.java:592)
          at com.vaadin.ui.AbstractComponent.attach(AbstractComponent.java:577)
          at com.vaadin.server.AbstractClientConnector.attach(AbstractClientConnector.java:592)
          at com.vaadin.ui.AbstractComponent.attach(AbstractComponent.java:577)
          at com.vaadin.server.AbstractClientConnector.attach(AbstractClientConnector.java:592)
          at com.vaadin.ui.AbstractComponent.attach(AbstractComponent.java:577)
          at com.vaadin.ui.AbstractComponent.setParent(AbstractComponent.java:484)
          at com.vaadin.ui.AbstractComponentContainer.addComponent(AbstractComponentContainer.java:210)
          at com.vaadin.ui.CssLayout.addComponent(CssLayout.java:120)
          at com.jumpmind.symmetric.console.ui.common.AbstractMenuScreen.addToView(AbstractMenuScreen.java:229)
          at com.jumpmind.symmetric.console.ui.common.AbstractMenuScreen$3.run(AbstractMenuScreen.java:160)
          at com.jumpmind.symmetric.console.ui.common.AbstractMenuScreen.buttonClick(AbstractMenuScreen.java:170)
          at sun.reflect.GeneratedMethodAccessor72.invoke(Unknown Source)
          at sun.reflect.DelegatingMethodAccessorImpl.invoke(DelegatingMethodAccessorImpl.java:43)
          at java.lang.reflect.Method.invoke(Method.java:497)
          at com.vaadin.event.ListenerMethod.receiveEvent(ListenerMethod.java:508)
          ... 36 more
Caused by: java.lang.IllegalArgumentException
          at sun.reflect.GeneratedMethodAccessor1105.invoke(Unknown Source)
          at sun.reflect.DelegatingMethodAccessorImpl.invoke(DelegatingMethodAccessorImpl.java:43)
          at java.lang.reflect.Method.invoke(Method.java:497)
          at org.vaadin.addons.lazyquerycontainer.AbstractBeanQuery.constructItem(AbstractBeanQuery.java:118)
          ... 64 more
TagsNo tags attached.

Activities

There are no notes attached to this issue.

Related Changesets

SymmetricDS: 3.7 962f3968

2016-03-27 19:49:25

chenson

Details Diff
0002538: Error on Incoming Batch Panel
0002538
mod - symmetric-core/src/main/java/org/jumpmind/symmetric/model/IncomingBatch.java Diff File

SymmetricDS: 3.8 86c39bab

2016-03-27 19:49:25

chenson

Details Diff
0002538: Error on Incoming Batch Panel
0002538
mod - symmetric-core/src/main/java/org/jumpmind/symmetric/model/IncomingBatch.java Diff File

Issue History

Date Modified Username Field Change
2016-03-27 19:48 chenson New Issue
2016-03-27 19:48 chenson Status new => assigned
2016-03-27 19:48 chenson Assigned To => chenson
2016-03-27 19:49 chenson Status assigned => resolved
2016-03-27 19:49 chenson Fixed in Version => 3.7.31
2016-03-27 19:49 chenson Resolution open => fixed
2016-03-27 20:00 chenson Changeset attached => SymmetricDS 3.7 962f3968
2016-03-29 14:13 chenson Status resolved => closed
2016-04-28 10:01 chenson Changeset attached => SymmetricDS 3.8 86c39bab