View Issue Details

IDProjectCategoryView StatusLast Update
0002540SymmetricDSBugpublic2019-08-26 08:45
ReporterDavid OrtegaAssigned Toelong 
Prioritynormal 
Status closedResolutionopen 
Product Version3.7.30 
Target VersionFixed in Version 
Summary0002540: Error during Insert or update with MS SQL Server 2014
DescriptionWe have a weird error, when we try to update a row with PK(1,1,24) it fails but when we update row PK(1,1,99) it works. All data are the same except the row autogenerated ID ( 24 or 99)



Examples:

[AGNUMAGE],[HONUMFIC],[GENUMTRA].[GETIPRE],[GENUTRAN],[GEPROV],[AAFECMOD],[AAUSUMOD]

1,1,24,RA,016501305200312,"IBERIA ",2016-03-28,10:07:32,"itFails "
1,1,99,RA,016501305200312,"IBERIA ",2016-03-28,10:07:32,"itWorks "
Steps To Reproduce1º update ATRIUM.TRANSAC SET AAUSUMOD = 'itWorks' where agnumage = 1 and honumfic = 1 and genumtra = 24

2º update ATRIUM.TRANSAC SET AAUSUMOD = 'itFails' where agnumage = 1 and honumfic = 1 and genumtra = 99


AAUSUMOD is just a text field
Additional Information2016-03-29 12:25:25,220 DEBUG [sqlserver-001] [YRCH] [sqlserver-001-pull-1] Añadiendo {itWorks ,1,1,99}
2016-03-29 12:25:25,234 INFO [as400-000] [RouterService] [as400-000-job-5] Routed 1 data events in 689 ms
2016-03-29 12:25:25,397 INFO [sqlserver-001] [PullService] [sqlserver-001-pull-1] Pull data received from as400:000:000. 1 rows and 1 batches were processed
2016-03-29 12:25:30,672 DEBUG [as400-000] [YRCH] [as400-000-job-6] Añadiendo {1630,293,as400_2_sqlserver} in batch mode
2016-03-29 12:25:30,988 INFO [as400-000] [RouterService] [as400-000-job-6] Routed 1 data events in 712 ms
2016-03-29 12:25:35,271 DEBUG [sqlserver-001] [YRCH] [sqlserver-001-pull-1] Añadiendo {itFails ,1,1,24}
2016-03-29 12:25:35,287 ERROR [sqlserver-001] [YRCH] [sqlserver-001-pull-1] Error en tranlsate I/O Error: Connection reset
java.sql.SQLException: I/O Error: Connection reset
    at net.sourceforge.jtds.jdbc.TdsCore.executeSQL(TdsCore.java:1093)
    at net.sourceforge.jtds.jdbc.JtdsStatement.executeSQL(JtdsStatement.java:563)
    at net.sourceforge.jtds.jdbc.JtdsPreparedStatement.execute(JtdsPreparedStatement.java:784)
    at org.apache.commons.dbcp.DelegatingPreparedStatement.execute(DelegatingPreparedStatement.java:172)
    at org.apache.commons.dbcp.DelegatingPreparedStatement.execute(DelegatingPreparedStatement.java:172)
    at org.jumpmind.db.sql.JdbcSqlTransaction$5.execute(JdbcSqlTransaction.java:319)
    at org.jumpmind.db.sql.JdbcSqlTransaction$5.execute(JdbcSqlTransaction.java:309)
    at org.jumpmind.db.sql.JdbcSqlTransaction.executeCallback(JdbcSqlTransaction.java:336)
    at org.jumpmind.db.sql.JdbcSqlTransaction.prepareAndExecute(JdbcSqlTransaction.java:309)
    at org.jumpmind.symmetric.db.mssql.MsSqlSymmetricDialect.enableSyncTriggers(MsSqlSymmetricDialect.java:340)
    at org.jumpmind.symmetric.service.impl.DataLoaderService$ManageIncomingBatchListener.enableSyncTriggers(DataLoaderService.java:937)
    at org.jumpmind.symmetric.service.impl.DataLoaderService$ManageIncomingBatchListener.beforeBatchEnd(DataLoaderService.java:875)
    at org.jumpmind.symmetric.io.data.DataProcessor.process(DataProcessor.java:128)
    at org.jumpmind.symmetric.service.impl.DataLoaderService$LoadIntoDatabaseOnArrivalListener.end(DataLoaderService.java:855)
    at org.jumpmind.symmetric.io.data.writer.StagingDataWriter.notifyEndBatch(StagingDataWriter.java:75)
    at org.jumpmind.symmetric.io.data.writer.AbstractProtocolDataWriter.end(AbstractProtocolDataWriter.java:220)
    at org.jumpmind.symmetric.io.data.DataProcessor.process(DataProcessor.java:130)
    at org.jumpmind.symmetric.service.impl.DataLoaderService.loadDataFromTransport(DataLoaderService.java:463)
    at org.jumpmind.symmetric.service.impl.DataLoaderService.loadDataFromPull(DataLoaderService.java:273)
    at org.jumpmind.symmetric.service.impl.PullService.execute(PullService.java:132)
    at org.jumpmind.symmetric.service.impl.NodeCommunicationService$2.run(NodeCommunicationService.java:396)
    at java.util.concurrent.ThreadPoolExecutor.runWorker(Unknown Source)
    at java.util.concurrent.ThreadPoolExecutor$Worker.run(Unknown Source)
    at java.lang.Thread.run(Unknown Source)
Caused by: java.net.SocketException: Connection reset
    at java.net.SocketInputStream.read(Unknown Source)
    at java.net.SocketInputStream.read(Unknown Source)
    at java.io.DataInputStream.readFully(Unknown Source)
    at java.io.DataInputStream.readFully(Unknown Source)
    at net.sourceforge.jtds.jdbc.SharedSocket.readPacket(SharedSocket.java:850)
    at net.sourceforge.jtds.jdbc.SharedSocket.getNetPacket(SharedSocket.java:731)
    at net.sourceforge.jtds.jdbc.ResponseStream.getPacket(ResponseStream.java:477)
    at net.sourceforge.jtds.jdbc.ResponseStream.read(ResponseStream.java:114)
TagsNo tags attached.

Activities

elong

2019-04-24 08:27

developer   ~0001425

The "connection reset" is when the network connection is knocked down unexpectedly. It would be unusual for a SQL statement to cause that error. Are you able to run the update manually from an interactive SQL query tool?

admin

2019-08-26 08:45

administrator   ~0001588

Auto closing all issues waiting for feedback after 4 months. We don't have enough information to take any action.

Issue History

Date Modified Username Field Change
2016-03-29 06:38 David Ortega New Issue
2019-04-24 08:27 elong Assigned To => elong
2019-04-24 08:27 elong Status new => feedback
2019-04-24 08:27 elong Note Added: 0001425
2019-08-26 08:45 admin Note Added: 0001588
2019-08-26 08:45 admin Status feedback => closed