View Issue Details

IDProjectCategoryView StatusLast Update
0002546SymmetricDSBugpublic2019-04-24 08:34
Reporterwoehrl01Assigned Toelong 
Prioritynormal 
Status closedResolutionfixed 
Product Version3.7.31 
Target VersionFixed in Version3.10.0 
Summary0002546: Foreign Keys Error not resolveable via INCOMING_ERROR resolve_ignore = 1
DescriptionI wanted to resolve a Foreign Key error via setting resolve_ignore = 1

But this is didn't work. As the exception gets propergated "to the top".
Because only Primary Key errors are marked as "CONFLICT".

I had to resolve this error by fully setting "OK" on the batch. But I think I have lost some other rows because of this.
I also have configured incoming.batches.skip.duplicates=false, and I had to manually set this to true, to make "OK"-ing work for incoming batches.

The question I have: Is this by intention?
And if yes, what would be the best way to resolve this without requiring to set incoming.batches.skip.duplicates=true?

If not I think you also have to check for IsForeignKeyViolation here:

https://github.com/JumpMind/symmetric-ds/blob/d5eec98ddc5092d0db53731349c0077c290a2d4e/symmetric-io/src/main/java/org/jumpmind/symmetric/io/data/writer/DefaultDatabaseWriter.java#L306

wouldn't it be better to resolve any exception via "resolve_ignore" on incoming batch instead of require to do this via "OK"?
TagsNo tags attached.

Relationships

duplicate of 0000827 closedjosh-a-hicks Allow any error (not only unique constraint errors) be fixed using sym_incoming_error 

Activities

woehrl01

2016-04-04 09:20

reporter   ~0000773

I referenced the delete, but I think the same should be true for insert/update, too. (I had the problem for an insert)

Issue History

Date Modified Username Field Change
2016-04-04 07:36 woehrl01 New Issue
2016-04-04 09:20 woehrl01 Note Added: 0000773
2019-04-24 08:34 elong Assigned To => elong
2019-04-24 08:34 elong Status new => closed
2019-04-24 08:34 elong Resolution open => fixed
2019-04-24 08:34 elong Fixed in Version => 3.10.0
2019-04-24 08:34 elong Relationship added duplicate of 0000827