View Issue Details

IDProjectCategoryView StatusLast Update
0002553SymmetricDSBugpublic2016-05-17 13:01
ReporteramarcellinAssigned Toelong 
PrioritynormalSeverityminorReproducibilityalways
Status closedResolutionfixed 
Product Version3.7.28 
Target Version3.7.33Fixed in Version3.7.33 
Summary0002553: REST : error on calling postStartByEngine
DescriptionREST API returns an error when I start my engine. No error on stop.
After stop, stated is stopped, after start, state is started.


<?xml version="1.0" encoding="UTF-8" standalone="yes"?><error><details>org.jumpm
ind.symmetric.web.rest.InternalServerErrorException&#xD;
        at org.jumpmind.symmetric.web.rest.RestService.startImpl(RestService.jav
a:1283)&#xD;
        at org.jumpmind.symmetric.web.rest.RestService.postStartByEngine(RestSer
vice.java:416)&#xD;
        at sun.reflect.NativeMethodAccessorImpl.invoke0(Native Method)&#xD;
        at sun.reflect.NativeMethodAccessorImpl.invoke(Unknown Source)&#xD;
        at sun.reflect.DelegatingMethodAccessorImpl.invoke(Unknown Source)&#xD;
        at java.lang.reflect.Method.invoke(Unknown Source)&#xD;
        at org.springframework.web.method.support.InvocableHandlerMethod.invoke(
InvocableHandlerMethod.java:215)&#xD;
        at org.springframework.web.method.support.InvocableHandlerMethod.invokeF
orRequest(InvocableHandlerMethod.java:132)&#xD;
        at org.springframework.web.servlet.mvc.method.annotation.ServletInvocabl
eHandlerMethod.invokeAndHandle(ServletInvocableHandlerMethod.java:104)&#xD;
        at org.springframework.web.servlet.mvc.method.annotation.RequestMappingH
andlerAdapter.invokeHandleMethod(RequestMappingHandlerAdapter.java:745)&#xD;
        at org.springframework.web.servlet.mvc.method.annotation.RequestMappingH
andlerAdapter.handleInternal(RequestMappingHandlerAdapter.java:686)&#xD;
        at org.springframework.web.servlet.mvc.method.AbstractHandlerMethodAdapt
er.handle(AbstractHandlerMethodAdapter.java:80)&#xD;
        at org.springframework.web.servlet.DispatcherServlet.doDispatch(Dispatch
erServlet.java:925)&#xD;
        at org.springframework.web.servlet.DispatcherServlet.doService(Dispatche
rServlet.java:856)&#xD;
        at org.springframework.web.servlet.FrameworkServlet.processRequest(Frame
workServlet.java:936)&#xD;
        at org.springframework.web.servlet.FrameworkServlet.doPost(FrameworkServ
let.java:838)&#xD;
        at javax.servlet.http.HttpServlet.service(HttpServlet.java:707)&#xD;
        at org.springframework.web.servlet.FrameworkServlet.service(FrameworkSer
vlet.java:812)&#xD;
        at javax.servlet.http.HttpServlet.service(HttpServlet.java:790)&#xD;
        at org.eclipse.jetty.servlet.ServletHolder.handle(ServletHolder.java:808
)&#xD;
        at org.eclipse.jetty.servlet.ServletHandler.doHandle(ServletHandler.java
:587)&#xD;
        at org.eclipse.jetty.server.handler.ScopedHandler.handle(ScopedHandler.j
ava:143)&#xD;
        at org.eclipse.jetty.security.SecurityHandler.handle(SecurityHandler.jav
a:577)&#xD;
        at org.eclipse.jetty.server.session.SessionHandler.doHandle(SessionHandl
er.java:223)&#xD;
        at org.eclipse.jetty.server.handler.ContextHandler.doHandle(ContextHandl
er.java:1127)&#xD;
        at org.eclipse.jetty.servlet.ServletHandler.doScope(ServletHandler.java:
515)&#xD;
        at org.eclipse.jetty.server.session.SessionHandler.doScope(SessionHandle
r.java:185)&#xD;
        at org.eclipse.jetty.server.handler.ContextHandler.doScope(ContextHandle
r.java:1061)&#xD;
        at org.eclipse.jetty.server.handler.ScopedHandler.handle(ScopedHandler.j
ava:141)&#xD;
        at org.eclipse.jetty.server.handler.HandlerWrapper.handle(HandlerWrapper
.java:97)&#xD;
        at org.eclipse.jetty.server.Server.handle(Server.java:499)&#xD;
        at org.eclipse.jetty.server.HttpChannel.handle(HttpChannel.java:310)&#xD
;
        at org.eclipse.jetty.server.HttpConnection.onFillable(HttpConnection.jav
a:257)&#xD;
        at org.eclipse.jetty.io.AbstractConnection$2.run(AbstractConnection.java
:540)&#xD;
        at org.eclipse.jetty.util.thread.QueuedThreadPool.runJob(QueuedThreadPoo
l.java:635)&#xD;
        at org.eclipse.jetty.util.thread.QueuedThreadPool$3.run(QueuedThreadPool
.java:555)&#xD;
        at java.lang.Thread.run(Unknown Source)&#xD;
</details><statusCode>500</statusCode></error>
Steps To ReproduceStop and then start engine using REST verbs postStopByEngine and postStartByEngine
Additional InformationIn org/jumpmind/symmetric/web/rest/RestService.java

"startImpl" method looks like

 if (engine.start()) {
            throw new InternalServerErrorException();

instead of
   if (engine.start() == false) {
TagsNo tags attached.

Activities

There are no notes attached to this issue.

Related Changesets

SymmetricDS: 3.7 90b82af9

2016-04-07 10:31:15

elong

Details Diff
0002553: REST : error on calling postStartByEngine
0002553
mod - symmetric-server/src/main/java/org/jumpmind/symmetric/web/rest/RestService.java Diff File

Issue History

Date Modified Username Field Change
2016-04-07 08:59 amarcellin New Issue
2016-04-07 10:29 elong Assigned To => elong
2016-04-07 10:29 elong Status new => assigned
2016-04-07 10:31 elong Status assigned => resolved
2016-04-07 10:31 elong Fixed in Version => 3.7.33
2016-04-07 10:31 elong Resolution open => fixed
2016-04-07 10:32 admin Target Version => 3.7.33
2016-04-07 11:00 elong Changeset attached => SymmetricDS 3.7 90b82af9
2016-05-17 13:01 chenson Status resolved => closed