View Issue Details

IDProjectCategoryView StatusLast Update
0002575SymmetricDSImprovementpublic2016-05-17 13:01
ReportermmichalekAssigned Tommichalek 
PrioritynormalSeverityminorReproducibilityalways
Status closedResolutionfixed 
Product Version3.7.32 
Target Version3.7.33Fixed in Version3.7.33 
Summary0002575: Support Primary Key Updates on Sybase ASE
DescriptionWhen updating the Primary Key of a captured table on Sybase ASE, the update will not get captured by the trigger. With this fix, a Sybase ASE trigger with USE_HANDLE_KEY_UPDATES=1 will capture updates to the primary key.

The change to the AseTriggerTemplate was modeled largely after the trigger definition in MsSqlTriggerTemplate, since these platforms share a lineage.
TagsNo tags attached.

Activities

There are no notes attached to this issue.

Related Changesets

SymmetricDS: 3.7 87f1dc84

2016-04-26 15:16:56

mmichalek

Details Diff
0002575: Support Primary Key Updates on Sybase ASE
0002575
mod - symmetric-client/src/main/java/org/jumpmind/symmetric/db/ase/AseTriggerTemplate.java Diff File

Issue History

Date Modified Username Field Change
2016-04-26 15:13 mmichalek New Issue
2016-04-26 15:13 mmichalek Status new => assigned
2016-04-26 15:13 mmichalek Assigned To => mmichalek
2016-04-26 15:18 mmichalek Status assigned => resolved
2016-04-26 15:18 mmichalek Resolution open => fixed
2016-04-26 15:18 mmichalek Fixed in Version => 3.7.33
2016-04-26 16:00 mmichalek Changeset attached => SymmetricDS 3.7 87f1dc84
2016-05-17 13:01 chenson Status resolved => closed