View Issue Details

IDProjectCategoryView StatusLast Update
0002578SymmetricDSBugpublic2016-05-17 13:01
ReporterelongAssigned Toelong 
PrioritynormalSeverityminorReproducibilityN/A
Status closedResolutionfixed 
Product Version3.7.0 
Target Version3.7.33Fixed in Version3.7.33 
Summary0002578: Staging can clear ready batches which slows initial load
DescriptionStaging manager will clear files when they are old even if they have not been synced yet. A batch is extracted to a file and named as READY. After the batch is synced, it is named as DONE. What can happen is the initial load extract in background extracts the batches, but they are so large that by the time they are sent and loaded, the staging file is already removed.

If READY staged files are abandoned, the user will need to clean them manually. We will address staging issues in 3.8 to fix this. For now, the user might cancel an initial load, which leaves READY files in staging, and they will need to clear staging manually.
TagsNo tags attached.

Activities

There are no notes attached to this issue.

Related Changesets

SymmetricDS: 3.7 5ff2ab5e

2016-04-27 09:56:11

admin

Details Diff
0002578: Staging can clear ready batches which slows initial load
0002578
mod - symmetric-io/src/main/java/org/jumpmind/symmetric/io/stage/StagingManager.java Diff File

SymmetricDS: 3.7 1803ab9d

2016-05-03 15:15:27

admin

Details Diff
0002578: Staging can clear ready batches which slows initial load
it looks like 0 is hard-coded to mean clean everything from staging

0002578
mod - symmetric-io/src/main/java/org/jumpmind/symmetric/io/stage/StagingManager.java Diff File

Issue History

Date Modified Username Field Change
2016-04-27 09:55 elong New Issue
2016-04-27 09:55 elong Status new => assigned
2016-04-27 09:55 elong Assigned To => elong
2016-04-27 09:57 elong Status assigned => resolved
2016-04-27 09:57 elong Fixed in Version => 3.7.33
2016-04-27 09:57 elong Resolution open => fixed
2016-04-27 10:00 admin Changeset attached => SymmetricDS 3.7 5ff2ab5e
2016-05-03 16:00 admin Changeset attached => SymmetricDS 3.7 1803ab9d
2016-05-17 13:01 chenson Status resolved => closed