View Issue Details

IDProjectCategoryView StatusLast Update
0002586SymmetricDS ProBugpublic2016-05-17 13:02
ReporterelongAssigned Toelong 
PrioritynormalSeverityminorReproducibilitysometimes
Status closedResolutionfixed 
Product Version3.7.0 
Target Version3.7.33Fixed in Version3.7.33 
Summary0002586: Incoming batch screen error when more than 1000 batches
DescriptionWhen more than 1000 batches accumulate, the incoming batches screen gets a NullPointerException. The exception is coming from the Vaadin component LazyQueryContainer. We're not using the laziness anyway, so switch to the BeanContainer instead.
Additional Information[gui] - AppUI - Invocation of method valueChange in com.jumpmind.symmetric.console.ui.screen.c.b$5 failed.
com.vaadin.event.ListenerMethod$MethodException: Invocation of method valueChange in com.jumpmind.symmetric.console.ui.screen.c.b$5 failed.
    at com.vaadin.event.ListenerMethod.receiveEvent(ListenerMethod.java:528)
    at com.vaadin.event.EventRouter.fireEvent(EventRouter.java:198)
    at com.vaadin.event.EventRouter.fireEvent(EventRouter.java:161)
    at com.vaadin.server.AbstractClientConnector.fireEvent(AbstractClientConnector.java:979)
    at com.vaadin.ui.AbstractField.fireValueChange(AbstractField.java:1131)
    at com.vaadin.ui.AbstractField.setValue(AbstractField.java:542)
    at com.vaadin.ui.AbstractSelect.setValue(AbstractSelect.java:702)
    at com.vaadin.ui.AbstractSelect.changeVariables(AbstractSelect.java:521)
    at com.vaadin.server.communication.ServerRpcHandler.changeVariables(ServerRpcHandler.java:485)
    at com.vaadin.server.communication.ServerRpcHandler.handleInvocations(ServerRpcHandler.java:301)
    at com.vaadin.server.communication.ServerRpcHandler.handleRpc(ServerRpcHandler.java:180)
    at com.vaadin.server.communication.UidlRequestHandler.synchronizedHandleRequest(UidlRequestHandler.java:93)
    at com.vaadin.server.SynchronizedRequestHandler.handleRequest(SynchronizedRequestHandler.java:41)
    at com.vaadin.server.VaadinService.handleRequest(VaadinService.java:1406)
    at com.vaadin.server.VaadinServlet.service(VaadinServlet.java:305)
    at com.jumpmind.symmetric.console.ui.AppServlet.service(AppServlet.java:36)
    at javax.servlet.http.HttpServlet.service(HttpServlet.java:790)
    at org.eclipse.jetty.servlet.ServletHolder.handle(ServletHolder.java:808)
    at org.eclipse.jetty.servlet.ServletHandler.doHandle(ServletHandler.java:587)
    at org.eclipse.jetty.server.handler.ScopedHandler.handle(ScopedHandler.java:143)
    at org.eclipse.jetty.security.SecurityHandler.handle(SecurityHandler.java:577)
    at org.eclipse.jetty.server.session.SessionHandler.doHandle(SessionHandler.java:223)
    at org.eclipse.jetty.server.handler.ContextHandler.doHandle(ContextHandler.java:1127)
    at org.eclipse.jetty.servlet.ServletHandler.doScope(ServletHandler.java:515)
    at org.eclipse.jetty.server.session.SessionHandler.doScope(SessionHandler.java:185)
    at org.eclipse.jetty.server.handler.ContextHandler.doScope(ContextHandler.java:1061)
    at org.eclipse.jetty.server.handler.ScopedHandler.handle(ScopedHandler.java:141)
    at org.eclipse.jetty.server.handler.HandlerWrapper.handle(HandlerWrapper.java:97)
    at org.eclipse.jetty.server.Server.handle(Server.java:499)
    at org.eclipse.jetty.server.HttpChannel.handle(HttpChannel.java:310)
    at org.eclipse.jetty.server.HttpConnection.onFillable(HttpConnection.java:257)
    at org.eclipse.jetty.io.AbstractConnection$2.run(AbstractConnection.java:540)
    at org.eclipse.jetty.util.thread.QueuedThreadPool.runJob(QueuedThreadPool.java:635)
    at org.eclipse.jetty.util.thread.QueuedThreadPool$3.run(QueuedThreadPool.java:555)
    at java.lang.Thread.run(Thread.java:745)
Caused by: java.lang.NullPointerException
    at org.vaadin.addons.lazyquerycontainer.LazyIdList.get(LazyIdList.java:92)
    at org.vaadin.addons.lazyquerycontainer.LazyQueryContainer.getIdByIndex(LazyQueryContainer.java:228)
    at com.vaadin.ui.Table.getIdByIndex(Table.java:1131)
    at com.vaadin.ui.Table.setCurrentPageFirstItemIndex(Table.java:1507)
    at com.vaadin.ui.Table.containerItemSetChange(Table.java:4545)
    at org.vaadin.addons.lazyquerycontainer.LazyQueryContainer.notifyItemSetChanged(LazyQueryContainer.java:443)
    at org.vaadin.addons.lazyquerycontainer.LazyQueryContainer.refresh(LazyQueryContainer.java:434)
    at com.jumpmind.symmetric.console.ui.screen.c.b.a(IncomingBatchPanel.java:540)
    at com.jumpmind.symmetric.console.ui.screen.c.b$5.valueChange(IncomingBatchPanel.java:177)
    at sun.reflect.NativeMethodAccessorImpl.invoke0(Native Method)
    at sun.reflect.NativeMethodAccessorImpl.invoke(NativeMethodAccessorImpl.java:62)
    at sun.reflect.DelegatingMethodAccessorImpl.invoke(DelegatingMethodAccessorImpl.java:43)
    at java.lang.reflect.Method.invoke(Method.java:483)
    at com.vaadin.event.ListenerMethod.receiveEvent(ListenerMethod.java:508)
    ... 34 more
TagsNo tags attached.

Activities

There are no notes attached to this issue.

Issue History

Date Modified Username Field Change
2016-05-03 13:01 elong New Issue
2016-05-03 13:01 elong Status new => assigned
2016-05-03 13:01 elong Assigned To => elong
2016-05-03 13:03 elong Status assigned => resolved
2016-05-03 13:03 elong Fixed in Version => 3.7.33
2016-05-03 13:03 elong Resolution open => fixed
2016-05-17 13:02 chenson Status resolved => closed