View Issue Details

IDProjectCategoryView StatusLast Update
0002599SymmetricDSBugpublic2016-05-17 13:01
ReporterabrougherAssigned Toabrougher 
PrioritynormalSeveritymajorReproducibilitysometimes
Status closedResolutionfixed 
Product Version3.7.32 
Target Version3.7.33Fixed in Version3.7.33 
Summary0002599: SqlScriptReader is parsing string literals from comments.
DescriptionThis causes the parser to look for the ending literal.

The following fails due to the (') in the contraction.

-- It's possible for a literal character to show up in comment contractions. See what I did there?
select * from foo;
TagsNo tags attached.

Activities

abrougher

2016-05-16 10:08

developer   ~0000791

Fixed. Includes unit test update.

Issue History

Date Modified Username Field Change
2016-05-16 10:07 abrougher New Issue
2016-05-16 10:07 abrougher Status new => assigned
2016-05-16 10:07 abrougher Assigned To => abrougher
2016-05-16 10:08 abrougher Note Added: 0000791
2016-05-16 10:08 abrougher Status assigned => resolved
2016-05-16 10:08 abrougher Fixed in Version => 3.7.33
2016-05-16 10:08 abrougher Resolution open => fixed
2016-05-16 10:10 chenson Project SymmetricDS Pro => SymmetricDS
2016-05-17 13:01 chenson Status resolved => closed