View Issue Details

IDProjectCategoryView StatusLast Update
0002608SymmetricDS ProBugpublic2016-08-16 15:36
ReporterelongAssigned Toelong 
PrioritynormalSeverityminorReproducibilityalways
Status closedResolutionfixed 
Product Version3.6.0 
Target Version3.8.1Fixed in Version3.8.1 
Summary0002608: Changing initial load delete SQL can break the configuration export
DescriptionWhen enabling the initial.load.delete.first and then changing the SQL it uses with initial.load.delete.first.sql can break the configuration export. When using "truncate table %s" for initial.load.delete.first.sql, the config export break because it tries to append a "where" statement. Make the config export always use "delete from %s".
TagsNo tags attached.

Activities

There are no notes attached to this issue.

Related Changesets

SymmetricDS: 3.8 60e7de98

2016-05-23 12:25:27

admin

Details Diff
0002608: Changing initial load delete SQL can break the configuration
export

0002608
mod - symmetric-core/src/main/java/org/jumpmind/symmetric/db/AbstractSymmetricDialect.java Diff File

Issue History

Date Modified Username Field Change
2016-05-23 12:25 elong New Issue
2016-05-23 12:25 elong Status new => assigned
2016-05-23 12:25 elong Assigned To => elong
2016-05-23 12:25 elong Status assigned => resolved
2016-05-23 12:25 elong Fixed in Version => 3.8.0
2016-05-23 12:25 elong Resolution open => fixed
2016-05-23 13:00 admin Changeset attached => SymmetricDS 3.8 60e7de98
2016-08-10 11:04 chenson Fixed in Version 3.8.0 => 3.8.1
2016-08-12 11:01 elong Target Version 3.8.0 => 3.8.1
2016-08-16 15:36 admin Status resolved => closed