View Issue Details

IDProjectCategoryView StatusLast Update
0002627SymmetricDSBugpublic2016-08-16 14:10
ReporternuralimcaAssigned Tojosh-a-hicks 
Priorityurgent 
Status resolvedResolutionno change required 
Product Version3.7.33 
Target VersionFixed in Version 
Summary0002627: initial.load.extract.and.send.when.staged when set to 'true' - not working for 8 or more batch size
DescriptionDear Friends,

I am using "initial.load.extract.and.send.when.staged" property which is newly introduced in version 3.7.33. Check - http://www.symmetricds.org/issues/view.php?id=2560.

When I set "initial.load.extract.and.send.when.staged" to "true", It works when batch_size if 7 or less than that. If batch size is 8 or more at that time Symmetric DS hangs at - org.jumpmind.symmetric.service.impl.OutgoingBatchService.updateOutgoingBatch(OutgoingBatchService.java:191).

Here is my Symmetric DS configuration:

** Configuration Starts:
insert into sym_channel
(channel_id, processing_order, max_batch_size, max_batch_to_send, max_data_to_route, enabled, reload_flag, contains_big_lob, description)
values('nmreload', 1, 1000, 1, 1000, 1, 1, 1, 'nm reload table data');

-- trigger MPLPART
insert into sym_trigger
(trigger_id,source_table_name,channel_id,reload_channel_id,use_capture_lobs, last_update_time,create_time)
values('MPLPART_T','MPLPART','nodemgr','nmreload',1,current_timestamp,current_timestamp);

insert into sym_trigger_router
(trigger_id,router_id,initial_load_order,initial_load_batch_count,initial_load_select,last_update_time,create_time)
values('MPLPART_T','onex_2_twox', 1, 0, 'ID <= 9500',current_timestamp, current_timestamp);
** Configuration Ends:

As I set initial_load_batch_count=0, Symmetric DS calculates no_of_batch. In my case no_of_records are 9500 and max_batch_size=1000 so it will created 10 batches and in this case Symmetric DS hangs. If no_of_records are less than 7000 then Symmetrid DS creates 7 batches and my scenario works.

Let me know in case need more details.

Thanks,
Nurali
Steps To Reproduceset "initial.load.extract.and.send.when.staged" to "true".
make sure to have 8 or more batches created for given table during Initial load.
TagsNo tags attached.

Activities

nuralimca

2016-06-08 01:45

reporter   ~0000803

Hi All,

I guess this is the regression introduced with new feature.
I am ready to fix the issue and do the require testing but I need some hint and guidance from this group on what may be the issue and what are the classes I need to check etc.

Thanks,
Nurali

nuralimca

2016-06-09 22:40

reporter   ~0000804

Hi All,

I got the solution.

Actually the issue with JDBC driver. I am having Sybase ASE database and was using jConnect JDBC driver. The thread getting hung due to jConnect driver. I change to use jTDS driver and issue solved.

Thanks for help and support.

Best Regards,
Nurali

Issue History

Date Modified Username Field Change
2016-06-03 06:18 nuralimca New Issue
2016-06-08 01:45 nuralimca Note Added: 0000803
2016-06-09 22:40 nuralimca Note Added: 0000804
2016-06-29 12:18 chenson Assigned To => josh-a-hicks
2016-06-29 12:18 chenson Status new => assigned
2016-06-29 12:18 chenson Target Version => 3.8.0
2016-08-08 11:11 admin Target Version 3.8.0 => 3.8.1
2016-08-16 14:09 elong Target Version 3.8.1 => 3.8.2
2016-08-16 14:10 elong Status assigned => resolved
2016-08-16 14:10 elong Resolution open => no change required
2016-08-16 14:10 elong Target Version 3.8.2 =>