View Issue Details

IDProjectCategoryView StatusLast Update
0002644SymmetricDSBugpublic2016-07-11 10:23
ReporterchensonAssigned Tochenson 
PrioritynormalSeverityminorReproducibilityhave not tried
Status closedResolutionfixed 
Product Version3.7.34 
Target Version3.7.35Fixed in Version3.7.35 
Summary0002644: Large float values fail to load on Sql Server
Description2016-06-22 08:32:08,882 INFO [client] [DefaultDatabaseWriter] [client-data-loader-1] Failed to process a insert event in batch 14.
Failed sql was: insert into "chenson"."dbo"."test" ("id", "col1") values (?,?)
Failed sql parameters: [1, 9.092000000000001E+40]
Failed sql parameters types: [4, 3]
Failed row data was: "1","9.092000000000001e+040"

2016-06-22 08:32:08,903 ERROR [client] [DataLoaderService] [client-data-loader-1] Failed to load batch server-14
org.jumpmind.db.sql.SqlException: BigDecimal value has more than 38 digits of precision.
    at org.jumpmind.db.sql.AbstractSqlTemplate.translate(AbstractSqlTemplate.java:283)
    at org.jumpmind.db.sql.AbstractSqlTemplate.translate(AbstractSqlTemplate.java:274)
    at org.jumpmind.db.sql.JdbcSqlTransaction.addRow(JdbcSqlTransaction.java:449)
    at org.jumpmind.symmetric.io.data.writer.DefaultDatabaseWriter.execute(DefaultDatabaseWriter.java:790)
    at org.jumpmind.symmetric.io.data.writer.DefaultDatabaseWriter.insert(DefaultDatabaseWriter.java:177)
    at org.jumpmind.symmetric.io.data.writer.AbstractDatabaseWriter.write(AbstractDatabaseWriter.java:155)
    at org.jumpmind.symmetric.io.data.writer.NestedDataWriter.write(NestedDataWriter.java:64)
    at org.jumpmind.symmetric.model.ProcessInfoDataWriter.write(ProcessInfoDataWriter.java:65)
    at org.jumpmind.symmetric.io.data.writer.NestedDataWriter.write(NestedDataWriter.java:64)
    at org.jumpmind.symmetric.io.data.writer.TransformWriter.write(TransformWriter.java:204)
    at org.jumpmind.symmetric.io.data.DataProcessor.forEachDataInTable(DataProcessor.java:200)
    at org.jumpmind.symmetric.io.data.DataProcessor.forEachTableInBatch(DataProcessor.java:170)
    at org.jumpmind.symmetric.io.data.DataProcessor.process(DataProcessor.java:116)
    at org.jumpmind.symmetric.service.impl.DataLoaderService$LoadIntoDatabaseOnArrivalListener$1.call(DataLoaderService.java:911)
    at org.jumpmind.symmetric.service.impl.DataLoaderService$LoadIntoDatabaseOnArrivalListener$1.call(DataLoaderService.java:1)
    at java.util.concurrent.FutureTask.run(FutureTask.java:266)
    at java.util.concurrent.ThreadPoolExecutor.runWorker(ThreadPoolExecutor.java:1142)
    at java.util.concurrent.ThreadPoolExecutor$Worker.run(ThreadPoolExecutor.java:617)
    at java.lang.Thread.run(Thread.java:745)
Caused by: java.sql.SQLException: BigDecimal value has more than 38 digits of precision.
    at net.sourceforge.jtds.jdbc.Support.normalizeBigDecimal(Support.java:184)
    at net.sourceforge.jtds.jdbc.JtdsPreparedStatement.setParameter(JtdsPreparedStatement.java:625)
    at net.sourceforge.jtds.jdbc.JtdsPreparedStatement.setBigDecimal(JtdsPreparedStatement.java:896)
    at org.apache.commons.dbcp.DelegatingPreparedStatement.setBigDecimal(DelegatingPreparedStatement.java:132)
    at org.apache.commons.dbcp.DelegatingPreparedStatement.setBigDecimal(DelegatingPreparedStatement.java:132)
    at org.springframework.jdbc.core.StatementCreatorUtils.setValue(StatementCreatorUtils.java:329)
    at org.springframework.jdbc.core.StatementCreatorUtils.setParameterValueInternal(StatementCreatorUtils.java:235)
    at org.springframework.jdbc.core.StatementCreatorUtils.setParameterValue(StatementCreatorUtils.java:166)
    at org.jumpmind.db.sql.JdbcSqlTemplate.setDecimalValue(JdbcSqlTemplate.java:1008)
    at org.jumpmind.db.sql.JdbcSqlTemplate.setValues(JdbcSqlTemplate.java:994)
    at org.jumpmind.db.sql.JdbcSqlTransaction.addRow(JdbcSqlTransaction.java:433)
    ... 16 more
TagsNo tags attached.

Activities

There are no notes attached to this issue.

Related Changesets

SymmetricDS: 3.7 c7b523a6

2016-06-30 14:26:05

chenson

Details Diff
0002644: Large float values fail to load on Sql Server
0002644
mod - symmetric-jdbc/src/main/java/org/jumpmind/db/platform/mssql/MsSql2000DatabasePlatform.java Diff File

Issue History

Date Modified Username Field Change
2016-06-22 11:19 chenson New Issue
2016-06-22 11:19 chenson Status new => assigned
2016-06-22 11:19 chenson Assigned To => chenson
2016-06-22 11:22 chenson Status assigned => resolved
2016-06-22 11:22 chenson Fixed in Version => 3.8.0
2016-06-22 11:22 chenson Resolution open => fixed
2016-06-22 11:23 chenson Fixed in Version 3.8.0 => 3.7.35
2016-06-22 11:23 chenson Target Version 3.8.0 => 3.7.35
2016-06-30 15:00 chenson Changeset attached => SymmetricDS 3.7 c7b523a6
2016-07-11 10:23 elong Status resolved => closed