View Issue Details

IDProjectCategoryView StatusLast Update
0000274SymmetricDSNew Featurepublic2014-08-27 21:02
ReporterAssigned Toelong 
PrioritynormalSeverityminorReproducibilityalways
Status closedResolutionfixed 
Product Version1.7.0 
Target VersionFixed in Version3.3.0 
Summary0000274: Allow keywords in table names (enable identifier delimiters)
Description"When creating tables on the target system, the ""create"" statement will fail if the source table has a column with a keyword. The ddl-utils library has the concept of an identifier delimiter, where the columns names would be surrounded with a character like a quote. Here is an example table: CREATE TABLE TEST ( ID VARCHAR(32) NOT NULL, START INTEGER NOT NULL, END INTEGER NOT NULL, PRIMARY KEY (ID) ) Investigate if we should set Platform.setDelimitedIdentifierModeOn(true) on all the platforms that can support it. The SQL-Server platform has it enabled, and it seems to work, but enabling the Postgres platform ran into some issues. We may need to patch/override ddl-utils to get it working. It looks like Postgres will may let you quote column names, but not other identifiers."
TagsNo tags attached.

Activities

There are no notes attached to this issue.

Issue History

Date Modified Username Field Change
2014-02-04 10:53 elong Status new => resolved
2014-02-04 10:53 elong Fixed in Version => 3.3.0
2014-02-04 10:53 elong Resolution open => fixed
2014-02-04 10:53 elong Assigned To => elong
2014-08-27 21:02 chenson Status resolved => closed