View Issue Details

IDProjectCategoryView StatusLast Update
0002740SymmetricDSBugpublic2016-08-22 16:26
ReporterelongAssigned Toelong 
PrioritynormalSeverityminorReproducibilitysometimes
Status closedResolutionfixed 
Product Version3.8.0 
Target Version3.8.2Fixed in Version3.8.2 
Summary0002740: "Did not receive an acknowledgement" using sym_table_reload_request
DescriptionWhen running an initial load or using sym_table_reload_request, the logs warn that acknowledgements are not received. The push is running to extract batches, but it skips batches with the extract_job_flag because those batches are extracting in the background. But it leaves the skipped batches in its list of processed batches, so it's expecting an acknowledgement for them that will not be received on that push. It's harmless warning, but skipped batches should be removed from the processed batch list.

WARN [client-1] [PushService] [client-1-push-default-1] Could not communicate with node 'server:server:server' because of unexpected error
org.jumpmind.symmetric.SymmetricException: Did not receive an acknowledgement for the batches sent. The 'ack string' was: '' and the 'extended ack string' was: 'null'
    at org.jumpmind.symmetric.service.impl.AbstractService.readAcks(AbstractService.java:320)
    at org.jumpmind.symmetric.service.impl.PushService.pushToNode(PushService.java:205)
    at org.jumpmind.symmetric.service.impl.PushService.execute(PushService.java:160)
    at org.jumpmind.symmetric.service.impl.NodeCommunicationService$1.run(NodeCommunicationService.java:479)
    at java.util.concurrent.ThreadPoolExecutor.runWorker(ThreadPoolExecutor.java:1142)
    at java.util.concurrent.ThreadPoolExecutor$Worker.run(ThreadPoolExecutor.java:617)
    at java.lang.Thread.run(Thread.java:745)
TagsNo tags attached.

Activities

There are no notes attached to this issue.

Related Changesets

SymmetricDS: 3.8 d1b62290

2016-08-18 12:24:24

admin

Details Diff
0002740: "Did not receive an acknowledgement" using
sym_table_reload_request

0002740
mod - symmetric-core/src/main/java/org/jumpmind/symmetric/service/impl/DataExtractorService.java Diff File

Issue History

Date Modified Username Field Change
2016-08-18 12:23 elong New Issue
2016-08-18 12:23 elong Status new => assigned
2016-08-18 12:23 elong Assigned To => elong
2016-08-18 12:25 elong Status assigned => resolved
2016-08-18 12:25 elong Fixed in Version => 3.8.2
2016-08-18 12:25 elong Resolution open => fixed
2016-08-18 13:00 admin Changeset attached => SymmetricDS 3.8 d1b62290
2016-08-22 16:26 elong Status resolved => closed