View Issue Details

IDProjectCategoryView StatusLast Update
0002751SymmetricDSBugpublic2019-04-24 09:07
ReportergwilmerAssigned Toelong 
Prioritynormal 
Status closedResolutionfixed 
Product Version3.7.38 
Target VersionFixed in Version3.10.0 
Summary0002751: Incorrect Trig/Capture on Oracle Dialect When Lob Data > 4k and Channel contains_big_log = 0 & trigger use_capture_lobs = 1
DescriptionIncorrect Trigger Capture on Oracle Dialect When Lob Data > 4k and Channel contains_big_lob = false & trigger use_capture_lobs = true
Steps To Reproduce1. Create Table with LOB field (preferably not last field in table)
2. Create trigger on table, set use_capture_lobs = 1, use default channel
3. Ensure default channel contains_big_lobs = 0
4. Insert a row containing a lob > 4k
5. Look at row_data on sym_data for the row.
Additional InformationBelow is partial look at sym_data.table_data. Note the end of the LOB column is missing its ed quote because it got truncated.

HLaFhaBNTk0L8El9JmxkZMympqYsqOfRyLLEXMCONXxV9mVpq2Jdubl2+HCLHT1yxA63HLJAILBt4Gn7joOPjP6d9pB9PB52OhKaHU+FHr+GaHNE1S3lUkQJ5Hp9qiVHFzu+rA2NXgBwcY5PlZBGEANnZ+cF+KLNz8/,"source","filenameorigin","333","444","

This is what sym_data.table_data looks like when the channel contains_big_lob is true (1)

s5NMx2rxSdQRPb294s37NVVTxR9nXDzjWm1iaqorHa/eqXYx/ec04Cz4C5KkYJGwht1OjuerUjGRf7sE9Y+NTUpq6Xf6GFoCj87PL1DAjPIHWMenbSmi68faiA0p7BhB7dC7PKxz36etOy7/fR4dd3Pv6y4h8K97nTIzyjdS9wAAAABJRU5ErkJggg==","source","filenameorigin","333","444","writedisk
TagsNo tags attached.

Relationships

related to 0003839 closedelong Trigger capture with fallback to slower use_capture_lob/contains_big_lob (Oracle) 

Activities

admin

2016-09-30 10:28

administrator   ~0000869

Re-opening. Was accidentally closed when performing the release.

Issue History

Date Modified Username Field Change
2016-08-25 07:28 gwilmer New Issue
2016-09-29 21:01 admin Status new => closed
2016-09-30 10:28 admin Status closed => new
2016-09-30 10:28 admin Note Added: 0000869
2019-04-24 09:06 elong Relationship added related to 0003839
2019-04-24 09:07 elong Assigned To => elong
2019-04-24 09:07 elong Status new => closed
2019-04-24 09:07 elong Resolution open => fixed
2019-04-24 09:07 elong Fixed in Version => 3.10.0