View Issue Details

IDProjectCategoryView StatusLast Update
0002782SymmetricDSBugpublic2016-09-16 09:00
ReporterelongAssigned Toelong 
PrioritynormalSeverityminorReproducibilitysometimes
Status closedResolutionfixed 
Product Version3.8.0 
Target Version3.8.4Fixed in Version3.8.4 
Summary0002782: Duplicate data gap immediately after upgrade
DescriptionVersion 3.7 has protection from inserting duplicate gaps because it is possible to get overlapping gaps in that version. In 3.8, the protection from duplicate gaps was removed because bugs around overlapping gaps were fixed. But when upgrading from 3.7 to 3.8, the data gap table could have overlapping gaps, which still causes duplicate gaps. Remove the data gaps when upgrading to 3.8 to force it to reset.
TagsNo tags attached.

Activities

There are no notes attached to this issue.

Related Changesets

SymmetricDS: 3.8 837b692f

2016-09-09 10:56:40

admin

Details Diff
0002782: Duplicate data gap immediately after upgrade
0002782
mod - symmetric-core/src/main/java/org/jumpmind/symmetric/db/DatabaseUpgradeListener.java Diff File

Issue History

Date Modified Username Field Change
2016-09-09 10:56 elong New Issue
2016-09-09 10:56 elong Status new => assigned
2016-09-09 10:56 elong Assigned To => elong
2016-09-09 10:57 elong Status assigned => resolved
2016-09-09 10:57 elong Fixed in Version => 3.8.4
2016-09-09 10:57 elong Resolution open => fixed
2016-09-09 12:00 admin Changeset attached => SymmetricDS 3.8 837b692f
2016-09-16 09:00 admin Status resolved => closed