View Issue Details

IDProjectCategoryView StatusLast Update
0002823SymmetricDSBugpublic2016-09-29 21:01
ReporterelongAssigned Toelong 
PrioritynormalSeverityminorReproducibilityalways
Status closedResolutionfixed 
Product Version3.7.0 
Target Version3.8.5Fixed in Version3.8.5 
Summary0002823: Value too large for router_id in sym_data_event error
DescriptionFor triggers on the SYM tables, the router_id is generated by concatenating the trigger_id with source_node_group_id and target_node_group_id, and then it is saved in sym_data_event during routing. If the user has specified large names in the configuration, the router_id will exceed the 50 characters defined for it on sym_data_event.

Caused by: java.sql.BatchUpdateException: value too large for column "SYM_DATA_EVENT"."ROUTER_ID" (actual: 51, maximum: 50)
TagsNo tags attached.

Activities

There are no notes attached to this issue.

Related Changesets

SymmetricDS: 3.8 1aa51b08

2016-09-22 11:09:21

admin

Details Diff
0002823: Value too large for router_id in sym_data_event error
0002823
mod - symmetric-core/src/main/java/org/jumpmind/symmetric/service/impl/TriggerRouterService.java Diff File

Issue History

Date Modified Username Field Change
2016-09-22 10:21 elong New Issue
2016-09-22 10:21 elong Status new => assigned
2016-09-22 10:21 elong Assigned To => elong
2016-09-22 12:00 admin Changeset attached => SymmetricDS 3.8 1aa51b08
2016-09-23 08:33 elong Resolution open => fixed
2016-09-23 08:33 elong Fixed in Version => 3.8.5
2016-09-23 08:33 elong Target Version => 3.8.5
2016-09-23 08:33 elong Status assigned => resolved
2016-09-29 21:01 admin Status resolved => closed