View Issue Details

IDProjectCategoryView StatusLast Update
0002825SymmetricDSBugpublic2016-09-29 21:01
ReportermmichalekAssigned Tommichalek 
PrioritynormalSeverityminorReproducibilityalways
Status closedResolutionfixed 
Product Version3.8.5 
Target Version3.8.5Fixed in Version3.8.5 
Summary0002825: Data with ID = 0 is routed perpetually when using DataGapFastDetector
DescriptionIn the unusual situation where a data has id of 0, SymmetricDS will route that piece of data over and over, creating a new batch ID each time. This only occurs when using the DataGapFastDetector.

This bug was known to happen on HSQLDB, whose IDENTITY counter actually starts at 0 on sym_data. Probably most RDBMS' start at 1, which inherently works around this issue.

The issue was that the RouterService would route the data with id 0, but when it tried to notify the ChannelRouterContext, the 0 data id was dropped because "lastDataId" variable was not initialized and was therefore already 0. So the next time around, the DataGapFastDetector didn't know that any data was found at 0, and presented a gap at 0 for the next routing query which would start the cycle over.

TagsNo tags attached.

Activities

There are no notes attached to this issue.

Related Changesets

SymmetricDS: 3.8 780bb97c

2016-09-22 16:00:51

mmichalek

Details Diff
0002825: Data with ID = 0 is routed perpetually when using
DataGapFastDetector

0002825
mod - symmetric-core/src/main/java/org/jumpmind/symmetric/route/ChannelRouterContext.java Diff File

Issue History

Date Modified Username Field Change
2016-09-22 15:59 mmichalek New Issue
2016-09-22 15:59 mmichalek Status new => assigned
2016-09-22 15:59 mmichalek Assigned To => mmichalek
2016-09-22 16:05 mmichalek Status assigned => resolved
2016-09-22 16:05 mmichalek Resolution open => fixed
2016-09-22 16:05 mmichalek Fixed in Version => 3.8.5
2016-09-22 17:00 mmichalek Changeset attached => SymmetricDS 3.8 780bb97c
2016-09-29 21:01 admin Status resolved => closed