View Issue Details

IDProjectCategoryView StatusLast Update
0002831SymmetricDSBugpublic2016-09-29 21:01
ReporterelongAssigned Toelong 
PrioritynormalSeverityminorReproducibilitysometimes
Status closedResolutionfixed 
Product Version3.8.0 
Target Version3.8.5Fixed in Version3.8.5 
Summary0002831: Newline converison in data can cause data truncation error
DescriptionThe newline characters in the batch CSV are being converted to the local platform when loading data, including data fields. A data field at the source might be New\nLine, but when it syncs to a Windows platform, it becomes New\r\nLine. (White space like newlines are allowed in the batch CSV because it is within a quoted field.)
TagsNo tags attached.

Activities

There are no notes attached to this issue.

Related Changesets

SymmetricDS: 3.8 9417b9ee

2016-09-27 15:14:02

admin

Details Diff
0002831: Newline converison in data can cause data truncation error
0002831
mod - symmetric-io/src/main/java/org/jumpmind/symmetric/io/data/writer/SimpleStagingDataWriter.java Diff File

Issue History

Date Modified Username Field Change
2016-09-27 15:08 elong New Issue
2016-09-27 15:08 elong Status new => assigned
2016-09-27 15:08 elong Assigned To => elong
2016-09-27 15:54 elong Status assigned => resolved
2016-09-27 15:54 elong Fixed in Version => 3.8.5
2016-09-27 15:54 elong Resolution open => fixed
2016-09-27 16:00 admin Changeset attached => SymmetricDS 3.8 9417b9ee
2016-09-29 21:01 admin Status resolved => closed