View Issue Details

IDProjectCategoryView StatusLast Update
0002841SymmetricDSNew Featurepublic2016-10-06 20:02
ReporterchensonAssigned Tochenson 
PrioritynormalSeverityminorReproducibilityhave not tried
Status closedResolutionfixed 
Product Version3.8.6 
Target Version3.8.6Fixed in Version3.8.6 
Summary0002841: Add a generic jdbc platform and symmetric dialect that will work with jdbc drivers that are not yet supported.
DescriptionAdd a generic jdbc platform and symmetric dialect that will work with jdbc drivers that are not yet supported. Triggers will not be supported as they cannot be build in a generic manner.
TagsNo tags attached.

Activities

There are no notes attached to this issue.

Related Changesets

SymmetricDS: 3.8 61391ff9

2016-10-02 16:32:23

chenson

Details Diff
0002841: Add a generic jdbc platform and symmetric dialect that will
work with jdbc drivers that are not yet supported.

0002841
mod - symmetric-android/src/main/java/org/jumpmind/symmetric/android/AndroidSqlTransaction.java Diff File
mod - symmetric-client/src/main/java/org/jumpmind/symmetric/db/JdbcSymmetricDialectFactory.java Diff File
add - symmetric-client/src/main/java/org/jumpmind/symmetric/db/generic/GenericSymmetricDialect.java Diff File
add - symmetric-client/src/main/java/org/jumpmind/symmetric/db/generic/GenericTriggerTemplate.java Diff File
mod - symmetric-client/src/main/java/org/jumpmind/symmetric/db/voltdb/VoltDbSymmetricDialect.java Diff File
mod - symmetric-client/src/main/java/org/jumpmind/symmetric/db/voltdb/VoltDbTriggerTemplate.java Diff File
mod - symmetric-core/src/main/java/org/jumpmind/symmetric/service/impl/DataService.java Diff File
mod - symmetric-db/src/main/java/org/jumpmind/db/platform/DatabaseNamesConstants.java Diff File
mod - symmetric-db/src/main/java/org/jumpmind/db/sql/ISqlTransaction.java Diff File
add - symmetric-db/src/main/java/org/jumpmind/db/sql/RowMapper.java Diff File
mod - symmetric-jdbc/src/main/java/org/jumpmind/db/platform/JdbcDatabasePlatformFactory.java Diff File
add - symmetric-jdbc/src/main/java/org/jumpmind/db/platform/generic/GenericJdbcDatabasePlatform.java Diff File
add - symmetric-jdbc/src/main/java/org/jumpmind/db/platform/generic/GenericJdbcDdlBuilder.java Diff File
add - symmetric-jdbc/src/main/java/org/jumpmind/db/platform/generic/GenericJdbcSqlDdlReader.java Diff File
add - symmetric-jdbc/src/main/java/org/jumpmind/db/platform/generic/GenericJdbcSqlTemplate.java Diff File
mod - symmetric-jdbc/src/main/java/org/jumpmind/db/platform/voltdb/VoltDbDatabasePlatform.java Diff File
mod - symmetric-jdbc/src/main/java/org/jumpmind/db/sql/JdbcSqlTemplate.java Diff File
mod - symmetric-jdbc/src/main/java/org/jumpmind/db/sql/JdbcSqlTransaction.java Diff File

SymmetricDS: 3.8 a73eeb7d

2016-10-02 20:45:59

chenson

Details Diff
0002841: Add a generic jdbc platform and symmetric dialect that will
work with jdbc drivers that are not yet supported. Can't reset meta
data result set on some platforms because it is forward only

0002841
mod - symmetric-jdbc/src/main/java/org/jumpmind/db/platform/generic/GenericJdbcDdlBuilder.java Diff File

SymmetricDS: 3.8 b85aa10f

2016-10-03 12:35:54

chenson

Details Diff
0002841: Add a generic jdbc platform and symmetric dialect that will
work with jdbc drivers that are not yet supported.

0002841
mod - symmetric-io/src/main/java/org/jumpmind/symmetric/io/data/DbExport.java Diff File

Issue History

Date Modified Username Field Change
2016-10-02 16:30 chenson New Issue
2016-10-02 16:30 chenson Status new => assigned
2016-10-02 16:30 chenson Assigned To => chenson
2016-10-02 17:00 chenson Changeset attached => SymmetricDS 3.8 61391ff9
2016-10-02 21:00 chenson Changeset attached => SymmetricDS 3.8 a73eeb7d
2016-10-03 13:00 chenson Changeset attached => SymmetricDS 3.8 b85aa10f
2016-10-06 09:23 chenson Status assigned => resolved
2016-10-06 09:23 chenson Fixed in Version => 3.8.6
2016-10-06 09:23 chenson Resolution open => fixed
2016-10-06 20:02 admin Status resolved => closed