View Issue Details

IDProjectCategoryView StatusLast Update
0002891SymmetricDS ProBugpublic2016-11-08 11:59
ReporterchensonAssigned Tochenson 
PrioritynormalSeverityminorReproducibilityhave not tried
Status closedResolutionfixed 
Product Version3.8.7 
Target Version3.8.8Fixed in Version3.8.8 
Summary0002891: Null Pointer on Dashboard
Description2016-11-07 18:11:07,395 ERROR [gui] [AppUI] [qtp851417480-12857] Invocation of method valueChange in com.jumpmind.symmetric.console.ui.b$2 failed.
com.vaadin.event.ListenerMethod$MethodException: Invocation of method valueChange in com.jumpmind.symmetric.console.ui.b$2 failed.
     at com.vaadin.event.ListenerMethod.receiveEvent(ListenerMethod.java:528)
     at com.vaadin.event.EventRouter.fireEvent(EventRouter.java:198)
     at com.vaadin.event.EventRouter.fireEvent(EventRouter.java:161)
     at com.vaadin.server.AbstractClientConnector.fireEvent(AbstractClientConnector.java:1008)
     at com.vaadin.ui.AbstractField.fireValueChange(AbstractField.java:1159)
     at com.vaadin.ui.AbstractField.setValue(AbstractField.java:570)
     at com.vaadin.ui.AbstractSelect.setValue(AbstractSelect.java:732)
     at com.vaadin.ui.AbstractField.setValue(AbstractField.java:468)
     at com.vaadin.ui.AbstractSelect.changeVariables(AbstractSelect.java:541)
     at com.vaadin.server.communication.ServerRpcHandler.changeVariables(ServerRpcHandler.java:603)
     at com.vaadin.server.communication.ServerRpcHandler.handleInvocations(ServerRpcHandler.java:422)
     at com.vaadin.server.communication.ServerRpcHandler.handleRpc(ServerRpcHandler.java:273)
     at com.vaadin.server.communication.UidlRequestHandler.synchronizedHandleRequest(UidlRequestHandler.java:79)
     at com.vaadin.server.SynchronizedRequestHandler.handleRequest(SynchronizedRequestHandler.java:41)
     at com.vaadin.server.VaadinService.handleRequest(VaadinService.java:1409)
     at com.vaadin.server.VaadinServlet.service(VaadinServlet.java:364)
     at com.jumpmind.symmetric.console.ui.AppServlet.service(AppServlet.java:37)
     at javax.servlet.http.HttpServlet.service(HttpServlet.java:790)
     at org.eclipse.jetty.servlet.ServletHolder.handle(ServletHolder.java:812)
     at org.eclipse.jetty.servlet.ServletHandler$CachedChain.doFilter(ServletHandler.java:1669)
     at org.jumpmind.symmetric.web.HttpMethodFilter.doFilter(HttpMethodFilter.java:62)
     at org.eclipse.jetty.servlet.ServletHandler$CachedChain.doFilter(ServletHandler.java:1652)
     at org.eclipse.jetty.servlet.ServletHandler.doHandle(ServletHandler.java:585)
     at org.eclipse.jetty.server.handler.ScopedHandler.handle(ScopedHandler.java:143)
     at org.eclipse.jetty.security.SecurityHandler.handle(SecurityHandler.java:577)
     at org.eclipse.jetty.server.session.SessionHandler.doHandle(SessionHandler.java:223)
     at org.eclipse.jetty.server.handler.ContextHandler.doHandle(ContextHandler.java:1127)
     at org.eclipse.jetty.servlet.ServletHandler.doScope(ServletHandler.java:515)
     at org.eclipse.jetty.server.session.SessionHandler.doScope(SessionHandler.java:185)
     at org.eclipse.jetty.server.handler.ContextHandler.doScope(ContextHandler.java:1061)
     at org.eclipse.jetty.server.handler.ScopedHandler.handle(ScopedHandler.java:141)
     at org.eclipse.jetty.server.handler.HandlerWrapper.handle(HandlerWrapper.java:97)
     at org.eclipse.jetty.server.Server.handle(Server.java:499)
     at org.eclipse.jetty.server.HttpChannel.handle(HttpChannel.java:311)
     at org.eclipse.jetty.server.HttpConnection.onFillable(HttpConnection.java:257)
     at org.eclipse.jetty.io.AbstractConnection$2.run(AbstractConnection.java:544)
     at org.eclipse.jetty.util.thread.QueuedThreadPool.runJob(QueuedThreadPool.java:635)
     at org.eclipse.jetty.util.thread.QueuedThreadPool$3.run(QueuedThreadPool.java:555)
     at java.lang.Thread.run(Thread.java:745)
Caused by: java.lang.NullPointerException
     at com.jumpmind.symmetric.console.ui.graph.ChannelStatsGraph.d(ChannelStatsGraph.java:150)
     at com.jumpmind.symmetric.console.ui.graph.ChannelStatsGraph.a(ChannelStatsGraph.java:209)
     at com.jumpmind.symmetric.console.ui.graph.ChannelStatsGraph.c(ChannelStatsGraph.java:340)
     at com.jumpmind.symmetric.console.ui.graph.ChannelStatsGraph.refresh(ChannelStatsGraph.java:336)
     at com.jumpmind.symmetric.console.ui.screen.a.d.a(GraphPanel.java:123)
     at com.jumpmind.symmetric.console.ui.screen.c.onRefresh(DashboardScreen.java:95)
     at com.jumpmind.symmetric.console.ui.screen.c.a(DashboardScreen.java:76)
     at com.jumpmind.symmetric.console.ui.b.refreshDashboard(MainWindow.java:771)
     at com.jumpmind.symmetric.console.ui.b.setSymmetricEngine(MainWindow.java:702)
     at com.jumpmind.symmetric.console.ui.b$2.valueChange(MainWindow.java:338)
     at sun.reflect.GeneratedMethodAccessor138.invoke(Unknown Source)
     at sun.reflect.DelegatingMethodAccessorImpl.invoke(DelegatingMethodAccessorImpl.java:43)
     at java.lang.reflect.Method.invoke(Method.java:606)
     at com.vaadin.event.ListenerMethod.receiveEvent(ListenerMethod.java:508)
TagsNo tags attached.

Activities

There are no notes attached to this issue.

Issue History

Date Modified Username Field Change
2016-11-07 18:29 chenson New Issue
2016-11-07 18:29 chenson Status new => assigned
2016-11-07 18:29 chenson Assigned To => chenson
2016-11-07 18:30 chenson Status assigned => resolved
2016-11-07 18:30 chenson Fixed in Version => 3.8.8
2016-11-07 18:30 chenson Resolution open => fixed
2016-11-08 11:59 chenson Status resolved => closed