View Issue Details

IDProjectCategoryView StatusLast Update
0002892SymmetricDSBugpublic2016-11-17 11:11
Reporterjosh-a-hicksAssigned Tochenson 
PrioritynormalSeverityminorReproducibilityalways
Status closedResolutionfixed 
Product Version3.8.9 
Target Version3.8.9Fixed in Version3.8.9 
Summary0002892: Monitor events cause issues when syncing to a node that is running SymmetricDS version less than 3.8.
DescriptionMonitor events are sent on the heartbeat channel and are a new feature in 3.8. So any networks containing 3.8 nodes and nodes running less than 3.8 will still sync these monitor events and cause issues while loading as the table is not present. The work around in the short term is to use a load filter to ignore these changes on a node that is running a lower version.
TagsNo tags attached.

Activities

chenson

2016-11-16 21:10

administrator   ~0000909

Is this a dupe of 0002757?

Related Changesets

SymmetricDS: 3.8 a7fec697

2016-11-17 10:41:50

chenson

Details Diff
0002892: Monitor events cause issues when syncing to a node that is
running SymmetricDS version less than 3.8.

0002892
mod - symmetric-core/src/main/java/org/jumpmind/symmetric/route/ConfigurationChangedDataRouter.java Diff File

Issue History

Date Modified Username Field Change
2016-11-08 12:31 josh-a-hicks New Issue
2016-11-08 12:31 josh-a-hicks Status new => assigned
2016-11-08 12:31 josh-a-hicks Assigned To => josh-a-hicks
2016-11-16 21:10 chenson Note Added: 0000909
2016-11-17 10:41 chenson Assigned To josh-a-hicks => chenson
2016-11-17 10:42 chenson Status assigned => resolved
2016-11-17 10:42 chenson Fixed in Version => 3.8.9
2016-11-17 10:42 chenson Resolution open => fixed
2016-11-17 11:00 chenson Changeset attached => SymmetricDS 3.8 a7fec697
2016-11-17 11:11 chenson Status resolved => closed